Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-31-2001, 04:12 AM
Registered User
 
Join Date: Jul 2001
Location: Boca Raton Florida
Posts: 26
1993 300E 2.8 MAF sensor?

Hello all my first post to the forum hope you can help

Yesterday my 300 started idleing very erratic , and also a huge hesitation when accelerating , sometimes it would dissapear but then return

Took it to a local shop who is knowledgeable but expensive(the owner was very helpful when i redid the top end of my 190e myself)

His scanner shows a bad MAF sensor code , but he is saying o2 sensor could be bad also , he quoted $450 for the maf replacement ,i know this is a simple swap ie hose clamo etc .

I came home removed the sensor check for possible dirt or obstructions , none . also removing the plug to sensor during idle does not change the condidtion still erratic . (any limp home on this system)?

any voltage or ohm checks i can perform to verify this is bad ? should i check anything else before i replace it? what should i be spending on a new bosch replacement?

any help appreciated

john derosa
__________________
1985 190 2.3
1993 300e 2.8
Reply With Quote
  #2  
Old 07-31-2001, 09:03 AM
pfphipps
Guest
 
Posts: n/a
I had the same problem a few months ago on my 93 300E2.8. Your problems sound familiar--surging and then back to a very low idle. Sometimes did it, sometimes not. At any time except idle, I really could not see any difference in the car's performance (even when accelerating) so I guess the "limp" mode is pretty good. And I could not see any difference with it disconneted. I could see nothing physically wrong with the sensor; it just did not work. Very simple fix (less than five minutes) but not cheap even when you do it yourself. I remember about $240 from Fast Lane. Still, it is a bit hard to spend that much for one part without knowing it is truly the problem. Can you find another 93-95 300E to swap sensors for a few minutes?
Reply With Quote
  #3  
Old 07-31-2001, 01:55 PM
Registered User
 
Join Date: Jul 2001
Location: Boca Raton Florida
Posts: 26
Trying

Calling and looking now , do you think 93-95 are the model years that will be the same ? does it matter if it is not a 2.8? trying to check cross reference #s with my local parts guy or gonna try calling fastlane now

ps , i wish i knew about this board a few years back , very informative spent 4 hours going through the posts and only got to post 900 , wish i knew about it when i had the 190e which i worked on myself (total top end redone )

thanks
__________________
1985 190 2.3
1993 300e 2.8
Reply With Quote
  #4  
Old 07-31-2001, 04:46 PM
pfphipps
Guest
 
Posts: n/a
Pretty sure they are the same up through 96 and the 3.2l engines use the same one as the 2.8l engines. They changed when they went to the V6.
Reply With Quote
  #5  
Old 07-31-2001, 06:20 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Your 1993 2.8 liter inline 6 cylinder had the M104 motor. Therefor, all motors from 93-97 that were either 3.2 liter (this includes 93 300E) or 2.8 *should* work. I am only ASSUMING this because they are the same motor. Correct me if I am wrong about the MAF being different to these engines.
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #6  
Old 08-01-2001, 01:03 AM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
I have the same problem on my 300E...it's intermittent now, but at one point this year, I went ahead and took the plunge and replaced the MAF...no change whatsoever after the replacement.

I had bought the part from Performance Products (my pre-forum days), and fortunately, they had a no-questions-asked refund policy.

I have yet to find the cause, but I DO know that it is not the MAF...look elsewhere.
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #7  
Old 08-01-2001, 12:17 PM
Registered User
 
Join Date: Jul 2001
Location: Boca Raton Florida
Posts: 26
got lucky i guess

Thank you all who posted replies

Purchased new bosch maf sensor today was gona order it from fastlane but being this is a daily driver needed it in a hurry , got it from worldpac/metrix , and it solved it , perfect idle now , no scan codes

pretty bulletproof car i must admit , 68k miles (virgin) so far as far as repairs set of plug wires 2 sets of plugs , drivers window regulator , and now a maf sensor, all diy .

now if i could find a set of 8 hole rims to replace those annoying to clean ones i have now i would be happy

thanks again

JD
__________________
1985 190 2.3
1993 300e 2.8
Reply With Quote
  #8  
Old 08-01-2001, 12:42 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Congratulations on your fix! I stand corrected.

By the way, FastLane has next-day delivery available as well. My 300E is also a daily driver, so I do next-day delivery when a must-have part goes south!

Wish FastLane would use FedEx though, (plug, plug). I hate answering the door with my FedEx t-shirt on, only to have the UPS guy greet me with a sly grin (me and him have a friendly war going on here).

I have chrome 8-holers, and they are not much easier to keep clean either...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E320 codes ahobgood Tech Help 24 05-26-2004 01:28 PM
What is the most common Benz? vanakin Off-Topic Discussion 14 12-07-2002 06:34 PM
FOR SALE: 1993 300E 2.8 Aaron Mercedes Used Parts For Sale & Wanted 0 04-07-2000 08:57 PM
1993 300E 2.8 FOR SALE Aaron Mercedes Used Parts For Sale & Wanted 0 11-01-1999 08:05 PM
1993 300E 2.8 For Sale Aaron Mercedes Used Parts For Sale & Wanted 0 08-14-1999 03:59 AM



All times are GMT -4. The time now is 12:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page