Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-06-2001, 02:59 PM
Gregg Vurbeff
Posts: n/a
450Sl Running Warm??

I was just given a beautiful 1973 450sl. We still can't believe it and have to go in the garage just to make sure that it is ours!! It's in great shape, has 188K, was rebuilt around 140K. Interior is almost perfect as is the paint. The owner had it completely stripped down to the metal and repainted at a cost of over $3K almost 15 years ago. I have all the records from day one. I need to know some info on the normal operating temp for these cars. It seems to me that it runs hot, at normal idle, the guage runs up between 200 and close to 275 but does not go into the thin red line. The aux. fan has yet to go on. I called our local Mercedes Dealership and talked to the parts dept. They said that this is normal for this year and make. He said that the aux fan will go on at 212 degrees, just at or below the red line?? He said not to worry and always gets calls from new owners of these cars. What should I expect?? A new radiator runs $400. that is if the old original cannot be recored? I have yet to take it to a shop. Also, it has not been tuned up since 1988, only 15K miles ago. It seems to skip at idle. We own a 78 300D and 84 300TD. I'm familar with these but not with this gas monster! Please help! Any info would be greatly appreciated
Reply With Quote
Old 08-06-2001, 06:38 PM
Southern's Avatar
Registered User
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605

A friend of mine also has a 73 450SL that was running hot (I'm not sure what the temp reading was). He took it to a local shop and they replaced the thermostat, his car did not run hot after that.

Hope this helps.
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
76 450sl not running on all cylinders, stalls at idle stew Open Discussion 0 12-02-2004 06:13 PM
1977 450sl blinking brake light and running hot abe g SL Forum 1 11-13-2004 07:17 PM
Running warm with A/C - and no aux fan! Ben300SD Tech Help 2 05-21-2001 02:06 PM
running warm 560 Paul Rondeau Tech Help 3 04-29-2001 10:51 AM

All times are GMT -4. The time now is 06:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page