Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2008, 02:18 PM
Tiyal's Avatar
Registered User
 
Join Date: Mar 2008
Posts: 3
Help 87 300e In Limp Mode

Aloha All,
this is my first Benz, just paid it off last week ,
Symptoms,
starts fine (purrs) warms up i can get about a mile normally then it down shifts to second and Im held at 25mph and 2800 rpm. I cant quite tell if its moving from 2nd to first or vice versa.
no lights, no over temps, all fluids full, no blown fuses
Maybe a clue, the coolant temp gauge seems erratic going from cold to red line then level 80-95 with intermittent pulses. I cleaned a little corrosion off both the fill level sensor and an unknown sensor below the reservoir.
Is it in limp / tranny gone? vac. system full of holes? get home mode where do i start?
What about reseting the computer?



Last edited by Tiyal; 03-31-2008 at 02:50 PM.
Reply With Quote
  #2  
Old 03-31-2008, 08:30 PM
Tiyal's Avatar
Registered User
 
Join Date: Mar 2008
Posts: 3
So far so good

I re-cleaned the sensor contacts and added a couple drops of a high-end gun-oil. Im still a little nervous to take it on the highway but i was able to get around town this afternoon with out getting stuck in second gear.
All this with a knife some research and a couple drops of oil.
Reply With Quote
  #3  
Old 04-01-2008, 06:18 PM
Registered User
 
Join Date: Dec 2000
Location: AL
Posts: 1,219
I don't believe the temp indicator is related to your transmission issue. I think the temp indicator has its own sensor and there is another sensor for sending info to the computer.

But the computer does nothing to control the trans in that car. The trans is supposed to delay the first 2-3 shift of the day to about 2500RPM in an effort to speed the warming of the cat. Assuming you have an American-market car with a cat.
__________________
2012 E350
2006 Callaway SC560
Reply With Quote
  #4  
Old 04-02-2008, 07:46 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,353
If it's shifting fine when cold, going into 4th gear, then dropping out of 3rd and 4th when warm, you've got internal leakage inside the tranny, and it's time for an overhaul.

Jim

__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page