Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-10-2008, 01:50 AM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
1986 190e 2.3 issues

hello all, i have a 1986 190e 2.3 that has recently developed several problems. it recently failed emmisions high (hc and co). i know the cat is bad and plan to replace it. i belive it went bad because of the engine not running properly. i have done a ton of searching and found it looks like i need to check the duty cycle, the fuel enrichment (it has been adjusted before by a previous owner im guessing),and the cold start injector. it is hard to start when cold, and recently i had to raise the idle using the stop bolt to make it idle high enough for the ac to run. i have also noticed that the dist. is rotated all the way to one side. im wondering if the p/o might have messed with it. does anyone have any info on checking / setting the timing? i am ready to attempt the duty cycle but there is one thing im confused on. i have this linkhttp://www.landiss.com/mixture.htm about using the x11 connector . is this the same for the 86? also any other info would be appreciated. i have always worked on the diesel mercedes and never really did much to the gas. i have been reading for the last 3 hours on this thing.

thank you

__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #2  
Old 05-10-2008, 02:05 AM
MTI's Avatar
MTI MTI is offline
Registered User
 
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,626
Quote:
Originally Posted by kmaysob View Post
hello all, i have a 1986 190e 2.3 that has recently developed several problems. it recently failed emmisions high (hc and co). i know the cat is bad and plan to replace it. i belive it went bad because of the engine not running properly.
Or it could just need replacement. If the engine runs rich, the excess fuel can damage the cat. Consider checking the O2 sensor to see if it is sending the proper voltage to the fuel computer (ECU) otherwise it will go to the very rich "limp home" mode.

Quote:
i have done a ton of searching and found it looks like i need to check the duty cycle, the fuel enrichment (it has been adjusted before by a previous owner im guessing),and the cold start injector. it is hard to start when cold, and recently i had to raise the idle using the stop bolt to make it idle high enough for the ac to run.
The idle isn't set by the stop bolt, the idle is adjusted via the air/fuel distributor.

Quote:
i have also noticed that the dist. is rotated all the way to one side. im wondering if the p/o might have messed with it. does anyone have any info on checking / setting the timing?
The position of the distributor doesn't advance or retard the timing, since that is controlled by the ignition system.

Before poking around the Bosch CIS fuel injection system, I would strongly suggest consulting the MB M102 Engine Manual.
Reply With Quote
  #3  
Old 05-10-2008, 02:46 AM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
that was my thought. i belive it is running rich, its also getting terrible fuel milage. i plan to test the o2 sensor tomorrow. it may not have been the stop bolt. i just remember it needing a higher idle in a hurry and adjusting a bolt to raise it. by chance do you have a link for the manual?
__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #4  
Old 05-12-2008, 08:26 AM
simmo1961's Avatar
Registered User
 
Join Date: Apr 2008
Posts: 8
check sencer plate for damage from engine back fire my 230e had hard cold start i have posted how to check it and fix it

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page