Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-18-2001, 11:34 PM
Registered User
Join Date: Aug 2001
Posts: 22
No Turn Signal Or Hazard


I have a 1987 260e (w124)
I have a problem with ma turn signals and hazard. None of them seem to be working at all. Nothing comes up at all when i turn them on. I would like to know if anyone knows what the problem is and if anyone knows where the flasher is located?????

Reply With Quote
Old 08-19-2001, 06:11 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
It's probably your COMBINATION relay. (How do your intermittent wipers work?) The relay is roughly $50 and can be purchased here. Also, try turning the hazard flashers on and off a few times. GOod luck!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 08-19-2001, 03:05 PM
Registered User
Join Date: Aug 2001
Posts: 22
Hey, my wipers work fine everything else works
perfectly fine except the turn signals and the hazards.
I played with the hazard lights but nothing is happening.
I dont know what to do?
please help and let me kno where the flasher is located?
Reply With Quote
Old 08-19-2001, 10:48 PM
mburman's Avatar
Registered User
Join Date: Jul 2001
Location: Tampa, FL
Posts: 69
replace your flasher unit.
71 MGB
76 450SL

United States Special Operations Command
Deployment Cell... Any Time, Any Place
Reply With Quote
Old 08-19-2001, 11:03 PM
hill's Avatar
Registered User
Join Date: Feb 2001
Location: Northern Calif Sacramento
Posts: 736
Hazard light switch

Where is the hazard light switch located on the dash or the console?
Happy Benzing
Darryl, Hill
2005 SL55 AMG Kleemanized
1984 500 SEC
1967 W113 California Coupe
Reply With Quote
Old 08-20-2001, 03:08 AM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
The problem can be either the flasher relay or the switch. It will be easier to debug it if you have the wiring diagram. You were saying that the intermittent wiper is working, then, your flasher relay is possibly okay.


Last edited by be459; 08-20-2001 at 03:25 AM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
sensitive turn signal lever jblackbu Tech Help 0 12-04-2004 02:22 PM
turn signal problem after steering box R&R rvolheim Tech Help 3 06-07-2003 04:19 PM
Turn Signal Hazard Lights not working kwat1109 Tech Help 0 05-13-2003 10:28 PM
Turn Signal Switch Tref Tech Help 1 08-20-2001 09:48 PM

All times are GMT -4. The time now is 03:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page