Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-21-2001, 08:57 PM
Posts: n/a
190e stalled again !! Help, stranded!!!

Just took my 1986 190e for a cruise after being down for about a week. It had stalled on me and would start up and run for maybe 15 seconds or so. After reading posts I installed a new fuel pump relay. (The first time it stalled out it sat for about an hour and when i went back to tow it home and it started and ran just fine. made it home ok) I drove it today with new relay installed about 10 miles. I could feel it surging before it finally quit. Felt like maybe running out of gas. Coasted in to parking lot where it still is. I put the old relay back in just to see what was going on. Same thing, runs about 5-10 seconds and dies. Please Help. I am open for suggestions. I hope after it sits for an hour or so it will make it back home. I did notice the tach going
Reply With Quote
Old 08-21-2001, 08:59 PM
Posts: n/a
I submitted before I got finished. sorry. I did notice the tach going a little crazy before it died. any help would be appreciated, Thanks
Reply With Quote
Old 08-21-2001, 09:36 PM
Registered User
Join Date: Aug 2001
Location: Toronto, Ontario
Posts: 33
Hi Rkc,

Having had a similar problem with my 190E, and having read thru a lot of other related threads, I would start by considering the following:

1) Clean gunk off Throttle Position Switch
2) Clean contacts on the Fuel Mixture Sensor and/or any other Fuel related sensors
3) Check fuse on OVP (Over Voltage Protector) and the OVP itself
4) Check Fuel Mixture Sensor
5) Replace Fuel Filter

I would do the first three checks myself and if it doesn't solve the problems, take it to a Mercedes garage to do the remaining tests (unless of course you can do it yourself)

Good Luck,
190E 2.3, 1988
Reply With Quote
Old 08-21-2001, 09:37 PM
Ashman's Avatar
Service Advisor
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
Have you checked fuel pump and or ovp yet?

Is the fuel pump delivering fuel at the proper rate?

Is the fuel filter dirty?

Are the spark plugs, distributor, coil, and other related components all good?

Is the Air Filter clean?

Is the throttle body dirty and gunked up?

These are things I would check or have checked.

I'm not a tech though, thats just what I would look at first.

'92 300CE - Sold
2004 C240 - C7 Wheels
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Mercedes Used Parts For Sale & Wanted 8 01-28-2005 09:45 PM
190E 2.3-16 parts for sale kiato4 Mercedes Used Parts For Sale & Wanted 2 06-25-2003 07:14 PM
i'm stranded in my office parking lot - 190e jhaycee Tech Help 10 06-11-2003 05:17 PM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Performance Paddock 3 04-22-2000 11:11 PM
stalled 190e frantz Tech Help 9 07-12-1999 08:29 AM

All times are GMT -4. The time now is 06:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page