Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-08-2008, 06:25 AM
Registered User
 
Join Date: Jan 2004
Posts: 185
Idle and KLIMA relay

Hi All

My idle does not seem to compensate when the compressor kicks in and cause the car to shudder before the idle climbs up again.

I am testing the KLIMA relay at pin 87Z and I get 0.15-0.16 V (compressor off/on). I tested the KLIMA on the bench with terminals 15/32 (12V/gnd) and activating terminal KL (via gnd). Am I testing it correctly and is 87Z supposed to show 12V with compressor on?

KLIMA p/n is 002 545 12 05

Regards
Andrew
__________________
1992 124 E200 (Euro)
Reply With Quote
  #2  
Old 06-09-2008, 06:14 PM
Registered User
 
Join Date: Jan 2004
Posts: 185
no one?
__________________
1992 124 E200 (Euro)
Reply With Quote
  #3  
Old 06-12-2008, 09:50 AM
Registered User
 
Join Date: Jan 2004
Posts: 185
Did I stump everyone???

Anyway - found the answer myself. KLIMA was faulty. Pin 87z was not putting out the 8-10V to raise the idle a split second before the compressor kicks in. Another symptom was engine dying immediately upon warm startup without gas pedal. The compressor was not disengaged for the initial start.

Someone will find this useful
__________________
1992 124 E200 (Euro)
Reply With Quote
  #4  
Old 03-14-2017, 01:17 PM
Registered User
 
Join Date: Mar 2017
Posts: 2
Quote:
Originally Posted by Oreo View Post
Did I stump everyone???

Anyway - found the answer myself. KLIMA was faulty. Pin 87z was not putting out the 8-10V to raise the idle a split second before the compressor kicks in. Another symptom was engine dying immediately upon warm startup without gas pedal. The compressor was not disengaged for the initial start.

Someone will find this useful
Thank you for this info

Information about KLIMA relays are so hard to find nowadays. I have a fully modified AC system which bypasses the KLIMA relay completely, the problem is that when the AC is turned ON the idle dips down and sometimes it stalls because there is no idle compensation for the AC Compressor.

I've been to numerous forums/mechanics trying to figure out on how to let the ECU know that the AC Compressor is engaged and to increase the idle respectively. No luck.

Until a few days back when I started reading about KLIMA relays (Mine was removed due to the modification). Realized some models came with the pin 87z on KLIMA which was responsible to trigger the ECU to increase the idle for the AC Compresor (pin 4 on female socket). But still didn't know whether it was a good idea to route +12v directly to pin 87z.

Until I saw your thread and confirmed my theory, if you supply pin 87z (pin 4) with +12v when the AC compressor is engaged, idle will increase by ~200rpm

Thank you again,
Regards
Reply With Quote
  #5  
Old 03-14-2017, 01:45 PM
Registered User
 
Join Date: Apr 2015
Location: Georgia, USA
Posts: 22
jackz08, Have you actually tried this? I have my KLIMA bypassed as well. I had tried from a schematic I found to provide the 12v to a pin (do not remember witch one) and it did not work.

I hope you were successful so I can duplicate your work.

Thanks
Joe
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page