Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2008, 02:59 PM
Registered User
 
Join Date: Jul 2008
Posts: 2
W124 300TE-24 cold idle problems

Hi, I bought myself a 1991 300TE-24 Auto estate a few weeks ago. I'm very pleased with it, but there are a few issues that need looking at, one of which is the idle after a cold start.

When started from cold, it will start quickly but cannot idle on its own; I have to keep blipping the throttle or the revs fall and the car will stall itself, there is also a smell of petrol from the exhaust when it is started from cold. After a few minutes the car idles fine and the petrol smell goes away.

Also, when I try to start it warm, it takes a few seconds to start. The starter motor turns normally but it just takes longer to fire, though once started it idles smoothly and runs fine.

Can anyone help?
Thanks.

Reply With Quote
  #2  
Old 07-28-2008, 10:22 PM
Registered User
 
Join Date: Oct 2004
Posts: 4,177
If you have the 104 engine in a 91 wagon, that is a rare bird. Is it an HFM setup or a CIS setup, diagnosing your problems are quite different between the two.
Reply With Quote
  #3  
Old 07-28-2008, 10:32 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
That would be a 104.980, so it is not HFM or DIS.
Same a 300CE 24.
__________________
A Dalton
Reply With Quote
  #4  
Old 07-29-2008, 07:29 AM
Registered User
 
Join Date: Jul 2008
Posts: 2
Quote:
Originally Posted by duxthe1 View Post
If you have the 104 engine in a 91 wagon, that is a rare bird. Is it an HFM setup or a CIS setup, diagnosing your problems are quite different between the two.
It is the M104 engine with the KE-Jetronic (or CIS) injection sytem.
Reply With Quote
  #5  
Old 07-29-2008, 07:38 AM
JayRash's Avatar
DON'T PANIC
 
Join Date: Jun 2005
Location: Beirut, Lebanon
Posts: 1,281
Quote:
Originally Posted by ms500 View Post
Hi, I bought myself a 1991 300TE-24 Auto estate a few weeks ago. I'm very pleased with it, but there are a few issues that need looking at, one of which is the idle after a cold start.

When started from cold, it will start quickly but cannot idle on its own; I have to keep blipping the throttle or the revs fall and the car will stall itself, there is also a smell of petrol from the exhaust when it is started from cold. After a few minutes the car idles fine and the petrol smell goes away.

Also, when I try to start it warm, it takes a few seconds to start. The starter motor turns normally but it just takes longer to fire, though once started it idles smoothly and runs fine.

Can anyone help?
Thanks.
Usually u can start by changing the ke-jet control relay located near the injection ecu behind the battery, itís a relay of considerable size and has a metal case with a red plastic top (as I recall)

__________________
Jay,
-----------------
-1995 Blue W202 C36 AMG (M) SOLD ;(
-1995 Black W140 S500 (Lady)
-1992 Black W124 E300 (Dima) (Ex-Mosselman
Twin turbo Kit).
-1988 Black W124 300 E 4-Matic.(Nadeen)
-1983 Brown W126 500SEL.(Old Lady)(Sold)
-1981 Gold W123 280CE.(Dareen)(Sold)
http://www.youtube.com/user/jayrasheed
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page