Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2001, 10:33 AM
Registered User
 
Join Date: Nov 2000
Location: Vernon, CT
Posts: 1,846
Turn signals not working, but hazards do

My neighbor just bought a car like mine and it has a curious turn signal problem. His hazards work fine, but when he goes to use his turn siganls, they only flash once then go out. Where is the relay for these lights?
__________________
1999 MB SL500 (101,000 mi)
1983 Porsche 911SC (149,000 mi)
2004 Volvo V70 2.5T (205,000 mi)
2014 Tesla Model S 85 (75,000 mi)
PCA member
MBCA member
Reply With Quote
  #2  
Old 09-01-2001, 09:19 PM
Registered User
 
Join Date: Nov 2000
Location: Vernon, CT
Posts: 1,846
Just an update to the problem. We found the relay box that is making the clicking sound, which would of course be the turn signal relay. Suspecting that this is bad we tried looking up the part number and it comes up as not listed. Anyone replace this relay and if so where did you source your part from? This relay is a silver box, with 5 pins and it's about 2 inches tall. The part number on the part is 107 820 01 10.
__________________
1999 MB SL500 (101,000 mi)
1983 Porsche 911SC (149,000 mi)
2004 Volvo V70 2.5T (205,000 mi)
2014 Tesla Model S 85 (75,000 mi)
PCA member
MBCA member
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Instrument panel dead, no turn signals Roger65 SL Forum 8 03-05-2004 11:48 AM
Turn signals quit. TurboTurbine Tech Help 5 02-15-2004 02:28 PM
79 240D - help trouble shoot - turn signals work intermittently jrmd01 Diesel Discussion 5 11-12-2003 09:19 PM
Turn Signal / Harzards Not Working?! odonnebj Diesel Discussion 1 01-23-2003 04:13 PM
Turn Signals mooch2 Tech Help 1 08-25-1999 12:37 PM



All times are GMT -4. The time now is 08:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page