Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-10-2008, 03:48 AM
Ocean View's Avatar
Registered User
 
Join Date: Feb 2005
Posts: 169
W210 M104 - Rough Idle and weird sounds after parked for 2 weeks.

Was wondering if others have had similar experience with cars parked for extended periods of time.
The idle did get smoother after a few miles but it was just so strange.
I've never experienced anything like this on this car.
__________________
2010 W212 E350 Sport
1996 W210 E320 (220K miles)
Reply With Quote
  #2  
Old 09-10-2008, 06:27 AM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Quite normal (at least for the M104). Age-related issues magnify the noises (dried belts, seals etc.).

Mine is normally smooth, but on occasion I've experienced rough idle at startup...even if only sitting for a few days.
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page