Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-08-2008, 11:10 AM
Registered User
 
Join Date: Sep 2008
Posts: 18
Question 98 SL500 Loss of power

Very confused about what the problem is here.
the car drives ok when driven gently but when you floor it, it looses all the power at 3500- 4000rpm is backfiring and it doesnt acelarate more.

I had a bad cat and was hoping this was the issue. I have replaced all the filters , spark plugs and cleaned the MAF with CRC's special product.

After all these , the problem was still there and decided to bite the bullet and go for the OEM cat. As i was driving to my indy the CEL came on.
I had 3 cylinders missfire and random missfire code. I was hoping that the clogged rattling catalytic converter was causing all this.

I had the cat installed yesterday and a O2 sensor as well. Took it for a drive and the problem is still there . The CEL came back on with the same codes exept one cylinder.First time was 2,4,8 and this time is 1,2,4.

I am very confused and have allready paid big bucks without any improvement at all. I ll have my indy change coils positions

Any help is appriciated..

Reply With Quote
  #2  
Old 10-08-2008, 06:42 PM
Registered User
 
Join Date: Sep 2008
Posts: 18
I switched the coils and took the car for a drive. The CEL came back on and Im S T I L L getting the same codes
Cylinders 1,2,4 missfire and random missfire.
So i guess its not the coils..

Now i really need some help here.....
Reply With Quote
  #3  
Old 10-09-2008, 05:25 PM
Registered User
 
Join Date: Sep 2008
Posts: 18
Today i replaced the coils at the missfiring cylinders with new ones .
Crossed fingures and ...... NO

The problem is still there. Missfire #1,#2,#4.
I am going to clean the injectors tomorrow..
This is unbelievable....!

Any help guys??
Reply With Quote
  #4  
Old 10-09-2008, 06:44 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Have you tried changing the plugs?
I usually start at the least expensive item and work my way back.

All that I can think of for now.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #5  
Old 10-10-2008, 08:32 AM
Registered User
 
Join Date: Sep 2008
Posts: 18
I have replaced the plugs and fuel filters first .
Im going nuts with this car....
Reply With Quote
  #6  
Old 10-10-2008, 08:15 PM
Registered User
 
Join Date: Sep 2008
Posts: 18
Today I had the injectors cleaned and changed positions .
Cleared the CEL once again. The car is still running very bad .
No improvment at its performance at all.. NOTHING ! ! !
Still when you step on it , the car is slow and is not rev up more than 3500 rpm. The CEL came on again when i floored it and i got the same codes again. Missfire #1,#2,#4 and random missfire ofcourse.

Tomorrow is time for the MAF to be replaced but i dont think will improve anything. Unfortunately its time for a compression test. We (me and my indy) are running out of options
Reply With Quote
  #7  
Old 10-10-2008, 08:26 PM
edsl94's Avatar
Registered User
 
Join Date: Jun 2008
Location: Feeding Hills MA.
Posts: 24
check the caps and rotors for tracking, clean them and scrape any corrosion from the posts and rotor tip. hows the fuel pressure? got a stuck open or leaking regulator? look for fuel in the vacuum line. does it hold vacuum? same with the egr valve. broken or cracked vacuum lines. stuffs gettin' on in age.
Reply With Quote
  #8  
Old 10-10-2008, 08:54 PM
Registered User
 
Join Date: Sep 2008
Posts: 18
Quote:
Originally Posted by edsl94 View Post
check the caps and rotors for tracking, clean them and scrape any corrosion from the posts and rotor tip. hows the fuel pressure? got a stuck open or leaking regulator? look for fuel in the vacuum line. does it hold vacuum? same with the egr valve. broken or cracked vacuum lines. stuffs gettin' on in age.
It doesnt have caps and rotors. It's an electronic ignition system, using coils. All the fuel system has been checked with and no issues found.
Its just so weird..
Reply With Quote
  #9  
Old 10-11-2008, 07:33 AM
Parrot of Doom's Avatar
1997 W210 E300TD 243,000
 
Join Date: Mar 2006
Location: Manchester, UK
Posts: 983
Maybe the vehicle's electrical system cannot supply enough power when under duress.
Reply With Quote
  #10  
Old 10-11-2008, 09:34 AM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
If the MAF doesn't fix the problem don't rule out bad gas, the symptoms are the same. A bottle of octane boost in the gas tank will "improve" a bad tank of gas until you can burn enough of it down.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #11  
Old 10-11-2008, 12:33 PM
Registered User
 
Join Date: Sep 2008
Posts: 18
Quote:
Originally Posted by Southern View Post
If the MAF doesn't fix the problem don't rule out bad gas, the symptoms are the same. A bottle of octane boost in the gas tank will "improve" a bad tank of gas until you can burn enough of it down.
I have driven the car for 500 miles (since i got the car) using only Shell Vpower and is still the same. I used STP injectors cleaner but it didnt help at all.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page