Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-24-2001, 03:56 PM
Steve Whiteside
Posts: n/a
Rough Downshift

I have recently noticed an automatic transmission malfunction on my '95 E320 wagon (W124) with 130,000miles.
The transmission operates silky smooth in all ranges, EXCEPT, when coasting up to a stopsign at about 10mph, I get a Rough Downshift (clunk).

[I have had this problem on my 123 diesels, and it always turns out to be a vacuum problem [leak], which is reducing vacuum to the modulator.]

I checked the M104 engine for loose vacuum lines/hoses and have found none. I pulled the vacuum connector from the second intake plenum and checked the line with a mighty vac & it held good vacuum (I think that on leads to the vac modulator on the automatic trans).

[I also have a check engine light on, but believe this is unrelated to the timing of the trans problem. (this car has the original engine harness).]

Any suggestions or components to check/replace are welcome.
Steve Whiteside
Reply With Quote
Old 10-11-2001, 07:43 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352

Did you ever find out why your transmission was making that noise? I have a similar problem.

2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
Rough idle after cold starting difficulty - related? Fintail Fan Tech Help 8 02-19-2003 10:38 AM
Rough smooth intermittent idle keithed Tech Help 7 12-07-2002 12:31 PM
300E rough rough rough idle MWG Tech Help 21 08-25-2002 09:30 PM
Rough 3-2 downshift Steve Wengel Tech Help 3 06-07-2000 09:22 PM

All times are GMT -4. The time now is 05:55 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page