Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-02-2001, 01:28 PM
Posts: n/a
Help please, electrical system shorting?

I own a 1987 2.3-16 in mint condition. In the last couple of days when the headlight is on, I noticed that whenever I turn the directional on the right, the windshield wiper turns on, it does not do this on the left. It also happens when I turn on the fog lights and when I turn the high beam on. When the fog lights and high beam are on, the wiper automatically turns on. I also noticed that the right side headlight and fog light are dimmer than the left side. I checked the fuses, they seem to be ok. Could the problem be in the headlight switch or the directional stalk.

Has anyone had this happen to them and if someone can help me diagnose it?

Thank you.

Reply With Quote
Old 10-02-2001, 03:04 PM
Posts: n/a
I am not so sure that the problem would be the stalk itself .But I think you have the problem isolated to the right area in the steering column. I would say that there are some wires in the steering column that run thru it toward the top by the stalk is where your problem is most likely to be .I hope this helps you a little .good luck
Reply With Quote
Old 10-02-2001, 06:12 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would check the combination relay. I have had these fail and cause things like this in the past.
Donnie Drummonds
Reply With Quote
Old 10-03-2001, 02:28 AM
Posts: n/a
thanks for the help....

I will check your suggestions today and I will let you guys know what happen.

Donnie, I assume, I should check the relays related to the washer, headlights and directionals.

Thanks again for the prompt reply. great forum.

Reply With Quote
Old 10-03-2001, 11:31 AM
Registered User
Join Date: Jun 2000
Location: Saugus, CA USA
Posts: 1,974
Not a short but an open

Sounds like you lost a ground somewhere. Is the wiper an intermittant, like at the same rate as the turn signal flashing:p
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question- electrical troubleshooting- oscillation temp gauge+ fuel gauge with turn ericgr SL Forum 5 09-30-2004 03:36 PM
Electrical system problem c280mike Tech Help 3 09-21-2004 03:09 PM
Car electrical fire crudsrus Tech Help 5 06-25-2004 11:45 PM
3 in vacuum at door system check valve - too low? pkmorgan17 Diesel Discussion 3 12-09-2002 09:22 PM
Need some help with the shorthand, fwiw suginami Open Discussion 4 06-27-2002 04:03 PM

All times are GMT -4. The time now is 09:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page