Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-02-2001, 07:06 PM
G.W. Pettry
Posts: n/a
Question 190E hard to start

Just bought a 1989 190E 2.6 .Car runs great after it starts...but have to turn ignition about 10 times before it catches, then runs at very slow and rough idle. After about 3 minutes you can tap the gas and it will rev up and go. Book says not to give it gas until it starts....its right! Give it gas and it doubles the start time. Someone said it needs a new "cold start valve"? Never heard of one.. my 300D doesnt have one....anyway, any suggestions ?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
M103 hard start, rough idle, hesitation SOLVED tryan Tech Help 9 02-12-2003 05:00 PM
190e voltage regulator, cold start valve, EHA Machnumber2 Tech Help 1 08-29-2002 07:50 PM
190E Hard Start D.McCarroll Tech Help 3 07-31-2002 09:30 PM
Can anyone help me to analyze: Hard start 400E... carman850 Tech Help 5 11-27-2001 07:22 AM
190E hard start meb Tech Help 9 03-11-2000 03:52 PM

All times are GMT -4. The time now is 01:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page