Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2009, 11:56 PM
89 Mercedes 300e,190 000k
 
Join Date: Dec 2008
Location: windsor, ontario, canada
Posts: 74
300E Blower Motore problem, please help

Hi i have a 91 300E 160 000 Km on it, the problem is that i melted the blower motor fuse on a hot summer day and replaced it with a Hd 30amp fuse and when i wired it and tested it, it worked fine. However now its winter and the motor only works when it wants to. Itll kick on for a few seconds and then shut off, sometimes never returning and its freezing out. Any suggestions would be helpful please thank you

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page