Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-15-2001, 07:45 PM
Posts: n/a
engine looses power after about an hour of driving

I just bought a 1983 300DT. I took it for a long drive this weekend and after about an hour I couldn't get it over 75. There was still about an inch or two of throttle left at 75 but when I pushed on the accelerator nothing would happen. The car shifts through all gears smoothly and the turbo works. What could be wrong?
Reply With Quote
Old 10-16-2001, 01:22 AM
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596

The car only goes 90 or so anyway, so you are nearing the end of the rpm range available. Losing power here can be either a breathing problem or a fuel problem. There are other possible problems but if it runs ok up to 75 mph, most of them are probably not the issue.

The air cleaner and valve adjustment may need attention, as they contribute to the breathing of the engine. Check the air cleaner, and replace it if it is dirty. The valves need to be adjusted and timed to do their job correctly, so these features should be checked and addressed as necessary.

The fuel system is pretty simple, and there are two filters on the inlet to the pump on the driver's side of the engine, plus a non-vented cap on the fuel tank. The filters need to be changed regularly as Diesel is often dirty. And if the venting system is not working the tank can develop a pretty strong vacuum that will limit the flow of fuel to the engine.

All this stuff is constantly under discussion here. Your problem description is not too clear so as you read the information about the valves, filters and other parts of the engine that may be suspect, be a little more specific about your question. For instance, I was expecting a car that would go fine when you started, but as time on the road built up, it would slow down, based on the title. Your description indicates the car just doesn't go more than 75mph. To give you much more specific help at least I need some more specifics about the problem.

Congratulations on you purchase, and if you are persistent I am sure we will be able to help you get more use and fun from the car than even Mercedes-Benz expected when they built it for you. Good Luck, Jim
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'98 E320 Power Steering and Trans. Leaks, M112 Engine DaveJ Tech Help 1 06-23-2004 10:39 PM
Loss of Power while Driving elaineq8 Tech Help 0 04-04-2004 06:29 AM
maintain engine power? Grdenko Diesel Discussion 6 10-16-2003 04:54 PM
280 SL engine power loss clipkarn Tech Help 9 11-20-2002 10:31 PM
92 300 SE LOOSES POWER biackbenz Tech Help 1 02-24-2001 11:32 AM

All times are GMT -4. The time now is 05:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page