Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-22-2001, 08:53 AM
Registered User
Join Date: Aug 2001
Location: Warsaw/Poland
Posts: 8
Unhappy W124 300TD alignment problem

I've got a problem with alignment on my 124 300TD (Wagon) '91 Sportline. I've got 7JxH2x15 alloy rims with ET25 (I think It's too low...) and 215/60R15 tires.
The problem is proper camber angle on front.
Two alignment computers told that the proper camber angle is 0.47 positive! But the mechanics told me that they can't set more then 0! But Auto-data catalog tells it should be 0.47 negative!
Could anybody tell me is it positive or neagtive and is 0.47 camber angle value should be OK for my car?
124 300TD '91
Reply With Quote
Old 10-22-2001, 05:41 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
W124 chassis MB's never used positive camber specs, on your car somewhere between -.025 & -.075 deg would be correct!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 10-23-2001, 04:24 PM
Registered User
Join Date: Aug 2001
Location: Warsaw/Poland
Posts: 8

Thanks for help! Now I'm sure.
124 300TD '91
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alignment problem? Or something else? BodhiBenz1987 Diesel Discussion 3 01-18-2005 01:29 PM
Alignment Caster Problem? ksing44 Tech Help 3 11-17-2004 08:12 AM
Problem with the windshield wiper (W124) Dimmi Tech Help 6 11-28-2003 06:59 PM
W124 -Warm Start problem - experience spirochete Tech Help 0 11-22-2003 05:00 AM
Another '94 W124 Air Cond. problem BadBenz94 Tech Help 3 08-23-2003 11:02 PM

All times are GMT -4. The time now is 10:46 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page