Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-28-2001, 10:27 PM
Super Moderator
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,315
Bizarre '73 280C Problem

Will also post this on the Vintage board.

So the big moment arrives. Senior Management and I are going for a ride in the 280C with its rebuilt engine with about 5 miles on it. The plan is to take Route 50 east to DC, then back to Falls Church via the GW Parkway and some back roads. Some quality miles on the new engine. Nice day for it, but a bit cool.

About 15 minutes out, the engine dies. No noise, nothing unusual, it just stops while cruising at 50 mph. Oil pressure pegged. Water temp a bit cool. Coast to a stop. Engine will not turn, despite lights, horn and a good solid thunk from the starter. Despair builds. Have car trucked home.

No clues. Lots of battery (12.75V), oil OK, coolant OK, no loose wires. Timing chain looks good. But acting like a seized engine. I despair and begin organizing tools for investigation. Out of curiosity, give key a try, and starter turns slowly and engine fires. Try it again, and engine starts and runs. Go around block like nothing ever happened.

Any ideas? TIA.
Chuck Taylor
Falls Church VA
'66 200, '66 230SL, '96 SL500. Sold: '81 380SL, '86 300E, '72 250C, '95 C220, 3 '84 280SL's '90 420SEL, '72 280SE, '73 280C, '78 280SE, '70 280SL, '77 450SL, '85 380SL, '87 560SL, '85 380SL, '72 350SL, '96 S500 Coupe
Reply With Quote
Old 10-28-2001, 10:45 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Fouled ignition points. Those cars used mechanically triggered transistor ignition and had almost no current flowing through the points. They insulate with the slightest smudge.

I have had brand new points out of the box leave me on the side of the road more than once. Drag a dollar bill through them and then grind them together (be sure they are closed first of course).
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 300CE W124 Doorlock Problem Ashman Tech Help 10 07-31-2004 09:37 PM
Please, please, please help! 87 300SDL Trans Problem pstutcher Diesel Discussion 2 07-21-2004 09:54 PM
Tormenting Problem with 95 E320 (Long) JetForeman Tech Help 16 10-01-2003 10:57 AM
S500 intermittent problem Edamartin Tech Help 4 06-10-2003 10:49 AM
HELP! Bizarre E Class light problem! groove1962 Tech Help 2 07-05-2002 08:18 AM

All times are GMT -4. The time now is 05:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page