Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-28-2009, 12:43 AM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
so confused, idle has a mind of its own.

my 190 16 valve has the strangest idle problem i have ever seen.

it follows no patter what so ever so im not even going to try to describe one.

but i can tell you that it idles as high as 2500 RPM or as low as 600. at 600 its almost dying.

most of the time it stumbles on the start up. like its missing a few ignitions. but after i give it some gas. it smooths out but then the above problem kicks it.

i replaced all the injector seals because they were old and dry and were letting air by. i checked my pouring water over the injectors. the engine coughed and spluttered.

but i am completely at a loss for the idle behavior of this car. and seeing as its supposed to be a highly tuned German racer. i embarrass my self when i drive it.

__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #2  
Old 09-28-2009, 08:50 AM
Registered User
 
Join Date: Sep 2009
Location: So Cal, No. Orange county
Posts: 108
I believe there are two switches involved in the throttle linkage, there may be an issue there
Bill
Reply With Quote
  #3  
Old 09-28-2009, 07:37 PM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
thread bump
__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #4  
Old 09-29-2009, 06:39 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
I see that you had vacuum leaks in your injector seals. Is it possible that somebody richened up the idle mixture in order to compensate for that? If so, then fixing the problem reveals the bad adjustments. Is your lambda tower still sealed, or has it been opened?

Also, check to make sure that your throttle linkage is adjusted properly, and moreover, that the idle switch is engaging when you take your foot of the gas. First check the switch for visible activation, then pull off the wires and hook up a meter and make sure that the switch electircally opens and closes as it should.
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #5  
Old 09-29-2009, 09:06 PM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
Quote:
Originally Posted by tinypanzer View Post
I see that you had vacuum leaks in your injector seals. Is it possible that somebody richened up the idle mixture in order to compensate for that? If so, then fixing the problem reveals the bad adjustments. Is your lambda tower still sealed, or has it been opened?

Also, check to make sure that your throttle linkage is adjusted properly, and moreover, that the idle switch is engaging when you take your foot of the gas. First check the switch for visible activation, then pull off the wires and hook up a meter and make sure that the switch electircally opens and closes as it should.

well i doubt somebody richened the idle mixture but its not out of the question. how would i go about checking that.

and about the lamda tower. no idea what that is. (i guess i don't know as much as i think i do). but again. help in checking.

the idle switch i will check ASAP.

i also just remembered that i am running very old spark plugs as far as i am concerned. will pull those and check their condition ASAP
__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #6  
Old 09-30-2009, 12:15 AM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
im taking the car in tomorrow. as it didn't pass SMOG in California. ??? i might just pay money to have them get it running like new and then maintain it from there.

i found an awesome shop in Burlingame in the bay area called ********e Shmid. and i know they understand Mercedes of our era because they have a freaking warehouse full of classic Mercedes.

some of them are for sale. i might buy a mid 70's 190D from them. in great running order just needs to be cleaned up
__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #7  
Old 10-05-2009, 09:24 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Quote:
Originally Posted by GregoryV022 View Post
well i doubt somebody richened the idle mixture but its not out of the question. how would i go about checking that.

and about the lamda tower. no idea what that is. (i guess i don't know as much as i think i do). but again. help in checking.

the idle switch i will check ASAP.

i also just remembered that i am running very old spark plugs as far as i am concerned. will pull those and check their condition ASAP
The Lambda tower is a metal tube that sits between the air meter intake and the fuel distributor. It lines up with the grommeted hole on top of your air cleaner housing. If it has a metal BB lodged in it, then it has never been monkeyed with. If the BB is missing, or the top of the tower sawed off, then it has.
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #8  
Old 10-06-2009, 08:07 PM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
Quote:
Originally Posted by tinypanzer View Post
The Lambda tower is a metal tube that sits between the air meter intake and the fuel distributor. It lines up with the grommeted hole on top of your air cleaner housing. If it has a metal BB lodged in it, then it has never been monkeyed with. If the BB is missing, or the top of the tower sawed off, then it has.
the car is with the indy right now. ill check it once it gets back.

as far as checking the idle switch. how would i go about doing that. i have a multimeter just very little practice in how to use it.
__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #9  
Old 10-07-2009, 05:07 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Well, let's see what your indy says and what he's able to fix. Then we'll dig into that.
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #10  
Old 10-07-2009, 09:37 PM
Greg
 
Join Date: Dec 2008
Location: San Carlos, California
Posts: 431
Quote:
Originally Posted by tinypanzer View Post
Well, let's see what your indy says and what he's able to fix. Then we'll dig into that.
my indy is replacing the plugged pre-cats. for $1000. that seems like a bit much.
__________________
Current
2006 E320 CDI, 57K bought at 67K "Liesl"
1986 190E 2.3-16, 198K bought at 56K "Brigitta"
1987 300TD (Chuggin Along), 292K "Friedrich"
1995 E320 Wagon, 200K "Louisa"

Past
1987 300SDL, (sold) 125K, bought for 1$ "Kurt"
Reply With Quote
  #11  
Old 10-07-2009, 09:40 PM
Registered User
 
Join Date: Sep 2009
Location: So Cal, No. Orange county
Posts: 108
The cats will cause a lack of power and if really restricted a poor idle or hard start but shouldn't have as much effect on varying of idle speed
Bill

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page