Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-14-2001, 09:02 PM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
Duty cycle Mayhem.....

Still messing with the duty cycle on my 86 300E and am still puzzled by a few things. My original problem was intermitent high idle, hot and cold, steady with occasional changes to another steady speed, always between 1400 and 650rpm. I started with duty cycle faults. None. I went to check duty cycles and, at Hot Idle (and I hope, closed loop) I get intermitent fixed 90.9%, then occasionally, I'll get a value that I can adjust by changing the mixture screw. It is hard to get a relatively steady closed loop reading. Tried to get the duty cycle reading between 40-50% but the damn thing goes all over the place. After being able to corner it in the lower 40"s, it starts to drop slowly until it hits 7.5%! and it goes back to Idling high for a minute or two, then back to the 40-50% range. I am out of ideas, but here is what I know 1)the EHA current is all over the place idling, Key on, engine off, it reads 13mA, 20mA is about right I am told. Idle speed control is at 300mA idling, duty cycle from 45% to occasionally as high as 70% 600-700 mA is normal I am told. What the hell is going on here? I got the car with the Idle problem and can't seem to get a base line to work from. I have disconnected the Oxy Sensor and got the light after a 3 mile drive and the car ran like crap, is my sensor weak? Any ideas would be great! Thanks
Reply With Quote
Old 11-14-2001, 09:04 PM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
PS I live at 6000 ft....... do I need to get a new Zero for the mixture (and disable the altitude sensors).
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another duty cycle question, specifically for Stevebfl ...sorry Greg in Oz Tech Help 4 06-22-2004 10:35 PM
'86 300E rich mixture - Duty cycle help bigschot Tech Help 15 11-13-2003 06:17 PM
K-Jet Duty Cycle Question Rato73 Tech Help 0 04-06-2003 07:58 PM
'87 300E cold start up integrator duty cycle? DieselGuy Tech Help 0 12-30-2001 03:11 PM
Fuel Trim? OBDII duty cycle, CHECK ENGINE ? ke6dcj Performance Paddock 1 08-07-2001 10:21 PM

All times are GMT -4. The time now is 05:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page