Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-20-2001, 09:59 AM
William Toth
Posts: n/a
Question 72 350 SL Loping Idle & No Power

We have a 72 350SL that has developed a loping idle problem and no power . The vehicle has 93,000 miles on it . We did a complete tune up , cap , rotor, points, plugs, wires, fuel filter . All of the parts were originals . The coil was also replaced , the tower had shorted badly to ground . Once the engine warms up it will idle but you can not accelerate at all , it begins to chug and miss . The fuel has been checked and is ok , firing lines on scope appear to be fine . We are not familiar with the transistorized module in the left fender well . What are the simptoms when it is going bad??? Also is there a way to check the on board computer. Can we also purchase parts from you ?? Everyone in the shop is pulling their hair out on this one , including the customer who calls regularly. Any help would be greatly appreciated on this one .


Reply With Quote
Old 11-20-2001, 10:58 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
IF you are a tech or owner of the shop, you can now send an e-mail to the and get a pass to go to the TECHS ONLY forum.

That said, I would check the vacuum hose that goes to the manifold pressure sensor.

Also, be sure to check the trigger points that are under the distributor housing. There is 4 sets of points that trigger the injectors and the will get wet with oil. If so, clean them and dry them to see if it helps.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
ICV-what's it for? and can high idle hurt trans? gmercoleza Tech Help 10 11-18-2004 10:16 PM
Rough idle and no power......(Gilly?) johng_22 ML, GL, G-Wagen, R-Class, Unimog, Sprinter 10 08-18-2004 11:18 PM
idle probs, loss of power, valves? bennylo Diesel Discussion 5 04-15-2003 07:56 AM
300 SD idle screw patsy Tech Help 5 12-04-2000 06:02 PM

All times are GMT -4. The time now is 10:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page