Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-23-2001, 12:49 PM
Jeff Kruger
Posts: n/a
1988 420 SEL brake activation shorts out instument's

If anybody has experience with this I would appreciate advice.
When I hit the brake pedal on my 88 420 SEL the fuel,temp,pressure,speedo,tach, etc.. all go to zero until you release brake pedal then all go back to normal. There is a slight hum when the brake pedal is hit kind of like a resistor noise.
the brake lights don't light either when this happens.
this problem is intermittent, everything works normal then all of a sudden the problem occurs.
Reply With Quote
Old 11-23-2001, 04:39 PM
Registered User
Join Date: Dec 2000
Location: Mt. Airy, Maryland
Posts: 116
I would check wires for worn insulation. It sounds like some wires are coming in contact with each other.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
420 sel flooding crusher Tech Help 8 09-06-2004 12:03 PM
1986 420 sel brake problem sebastian Performance Paddock 1 09-01-2002 11:25 PM
1988 420 SEL high speed shake bermuda Tech Help 1 05-27-2001 04:44 PM
420 sel timing chains, BRAKE PADS ken Tech Help 1 05-29-1999 11:28 AM

All times are GMT -4. The time now is 06:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page