Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2010, 05:16 PM
hispassion's Avatar
I Want A 1935 500K!
 
Join Date: Nov 2006
Location: Peoria, Arizona
Posts: 112
1992 300CE M104 Check Engine Light (code 11)

Well, I scoured this forum for a possible solution to my newest code, but to no avail.

I was able to read and clear the code. The guide that I have states that code 11 is a problem with the air injection system and likely an open or short circuit.

Any thoughts as to where one should begin and what might be most probable? If this topic has been discussed before, please direct me to that thread.

Any help is appreciated.

Thanks!

Michael B.

__________________
1992 300CE - 157kMi (my white beauty)
1992 300CE - 220kMi (sold)
1990 300E - 189kMi (sold)
1990 300SL - 102kMi (salvaged parts available)
1986 300E - 230kMi (salvaged parts available)

Expert RV Generator Repair
Go To: MiGen Repair
When no one else can, I do!

We judge ourselves by our intent.
We judge others by their actions.
Reply With Quote
  #2  
Old 01-25-2010, 08:18 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Broken vacuum line from switch-over valve to diverter valve is most common issue.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 01-25-2010, 09:01 AM
hispassion's Avatar
I Want A 1935 500K!
 
Join Date: Nov 2006
Location: Peoria, Arizona
Posts: 112
Thank you Mr. Moderator! I'll begin there tonight and report my findings.
__________________
1992 300CE - 157kMi (my white beauty)
1992 300CE - 220kMi (sold)
1990 300E - 189kMi (sold)
1990 300SL - 102kMi (salvaged parts available)
1986 300E - 230kMi (salvaged parts available)

Expert RV Generator Repair
Go To: MiGen Repair
When no one else can, I do!

We judge ourselves by our intent.
We judge others by their actions.
Reply With Quote
  #4  
Old 03-27-2010, 05:52 PM
hispassion's Avatar
I Want A 1935 500K!
 
Join Date: Nov 2006
Location: Peoria, Arizona
Posts: 112
Vacuum is present at the switchover and diverter valves. However, the Check Engine Light (CEL) comes on about 24 hours after the code is pulled and reset. I have two 300CE's of the same year and they sound the same on start up (air pump noise), but for some reason, the one in question keeps setting code (11).

I don't really want to do this, but one thought I have is to maybe swap switchover valves (from car to car) to see if the code appears on the other one.

Is there something else I should check?

Thanks for the help!
__________________
1992 300CE - 157kMi (my white beauty)
1992 300CE - 220kMi (sold)
1990 300E - 189kMi (sold)
1990 300SL - 102kMi (salvaged parts available)
1986 300E - 230kMi (salvaged parts available)

Expert RV Generator Repair
Go To: MiGen Repair
When no one else can, I do!

We judge ourselves by our intent.
We judge others by their actions.
Reply With Quote
  #5  
Old 03-29-2010, 10:18 AM
hispassion's Avatar
I Want A 1935 500K!
 
Join Date: Nov 2006
Location: Peoria, Arizona
Posts: 112
1992 300CE M104 Check Engine Light (code 11)

Anyone got any ideas? Where to look or how to test? Thanks!
__________________
1992 300CE - 157kMi (my white beauty)
1992 300CE - 220kMi (sold)
1990 300E - 189kMi (sold)
1990 300SL - 102kMi (salvaged parts available)
1986 300E - 230kMi (salvaged parts available)

Expert RV Generator Repair
Go To: MiGen Repair
When no one else can, I do!

We judge ourselves by our intent.
We judge others by their actions.
Reply With Quote
  #6  
Old 03-29-2010, 07:53 PM
Registered User
 
Join Date: Dec 2007
Location: NorCal
Posts: 1,332
Have you tried swapping the valves from car to car.....
__________________
http://i193.photobucket.com/albums/z...-RESIZED-1.jpg
1991 300E - 212K and rising fast...
Reply With Quote
  #7  
Old 04-05-2010, 10:08 PM
hispassion's Avatar
I Want A 1935 500K!
 
Join Date: Nov 2006
Location: Peoria, Arizona
Posts: 112
Nope. However, she's now for sale and the new owner picks it up Wednesday.

__________________
1992 300CE - 157kMi (my white beauty)
1992 300CE - 220kMi (sold)
1990 300E - 189kMi (sold)
1990 300SL - 102kMi (salvaged parts available)
1986 300E - 230kMi (salvaged parts available)

Expert RV Generator Repair
Go To: MiGen Repair
When no one else can, I do!

We judge ourselves by our intent.
We judge others by their actions.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page