Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-29-2001, 08:58 PM
Posts: n/a
'92 300se high beam repair

Does anyone know why my headlights go out when I switch from my low beams to my high beams. Low beams act as they should.
No dealer has been able to advise me on the solution.
Please contact me at if anyone has any suggestions or experience with this problem. Thanks.
Reply With Quote
Old 11-29-2001, 09:20 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have seen two things

1. stalk switch
2. both bulbs
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
High beam stop working W210 Brad E430 Tech Help 3 04-05-2004 07:37 PM
high beam inop DVanpraag Tech Help 1 04-03-2004 09:38 PM
High mileage Owners- Engine vs Repair sdent SL Forum 3 07-23-2002 08:21 AM
Passenger side high beam (headlights) Agron80 Tech Help 2 05-16-2000 10:28 AM
High Beam on 126 Head Lights H. O. Tyler Tech Help 1 04-21-2000 06:31 PM

All times are GMT -4. The time now is 12:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page