Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-14-2000, 01:57 AM
Registered User
Join Date: Mar 2000
Posts: 217
As i turn on the headlights which work perfectly, the passenger side high beam fails until i put the highbeams on. When I pull the lever to "flash" someone, the exterior light failure light comes on, and both headlights illuminate. When I push the lever to keep on the high beams, the exterior lights failure comes on and the passenger side headlight completely goes off. What could be the problem?? Bad bulb??

1989 300E (107k miles)
Reply With Quote
Old 05-14-2000, 12:56 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Sounds like a bulb to me.
Reply With Quote
Old 05-16-2000, 10:28 AM
Rick Miley's Avatar
Spark Free
Join Date: Jun 1999
Location: Tampa, FL
Posts: 3,079
My 87 300E acted similarly when the plug was melted. Check the condition of it when you pull it off to change the bulb. If melted, you can buy a replacement plug from NAPA and splice it in. No other auto parts store had one when I searched, and MB will only sell the whole headlight assy.

Rick Miley
99 E300 TurboDiesel
00 Jetta TDI
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 Passenger Side Squeak Found! stephenson Tech Help 5 07-12-2004 07:26 AM
Passenger side hot...Driver side cold Habanero Diesel Discussion 1 09-29-2003 11:29 PM
passenger side window trouble adiaw83 Tech Help 6 06-09-2003 12:06 AM
Drivers side lock same as passenger side? MVK Diesel Discussion 17 07-28-2002 02:31 PM
Passenger side air bag deployment ? Potomac Pat Tech Help 1 06-07-2002 05:18 PM

All times are GMT -4. The time now is 09:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page