Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-05-2001, 11:12 AM
Registered User
Join Date: Aug 2001
Location: Texas
Posts: 79
Unhappy Poor gas economy

I am getting 13 miles to the gallon. My car is not burning oil/leaking, but when I get out of my car there is a smell of fuel/raw eggs. Whats the problem? Air/fuel mixture? O2 sensor? Time for a tune up? Also my aux fans NEVER come on, the relay is fine. Its it the fans themselves? Since the fans do not come on I do not use the AC.
Reply With Quote
Old 12-05-2001, 11:25 AM
Registered User
Join Date: Aug 2001
Location: Texas
Posts: 79
sorry...1992 300e 129 k mi
Reply With Quote
Old 12-05-2001, 11:27 AM
Registered User
Join Date: Jun 2000
Location: Tucson, Arizona, USA
Posts: 180
Edit: What model?--oops, just missed your post. The smell seems like you are running at rich stop due to some sort of computer failure to control the mixture. Many possibilities . . .The O2 sensor and cat could take on damage if left too long. Manual mixture adjustment could be a temporary fix. I will leave it to others to suggest better solutions. Cheers, Andrew Seidel.
86 560SEC
85 500SEC Lorinser
83 300D Turbo
75 240D

Last edited by 5banger; 12-05-2001 at 11:34 AM.
Reply With Quote
Old 12-05-2001, 12:57 PM
Registered User
Join Date: Jun 2000
Location: Saugus, CA USA
Posts: 1,974
Does it come up to temperature? I had a thermostat break such that it was always open. The engine was always cold, ran open loop, and other cold engine things. But its better than breaking such that it was always closed
Reply With Quote
Old 12-06-2001, 10:18 AM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
The raw eggs smell is the sulphur from the catalytic converter...perhaps is clogged? That would hurt your mpgs tremendously!
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 12-07-2001, 06:10 AM
Registered User
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
I agree that if you are getting strong sulpher smells you likely have a problem with the cat converter and may need a new one. This would really screw with your mpgs.
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote
Old 12-07-2001, 08:22 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Check coolant temp -- should be 87 C or so. If not, bad thermostat. Easy to fix.

If the temp is OK, you have a bad temperature sensor -- this is why your aux fans won't run. Get it replaced, again easy. Could have a broken wire, too, althoug this is rare with a Mercedes (NOT with Volvo, though!).

You are running in open loop startup mode -- will kill your milage, your ox sensor, and your catalyst. Catalyst is expensive!

You may also have a bad fuel distributor if you have the older fuel injection system -- common problem. I don't know when MB changed to the LH type from the K-Jetronic. If the distrubutor is bad, it will be expensive to fix, and my mechanic has been having fits getting good replacements -- put three on a car before he got one that lasted more than 5000 miles! If it is bad, you will be trailing black smoke!

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 12-07-2001, 09:29 PM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270
The smell is a catylitic issue..what ever else is in play the smell is the catylitic converter

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Claim of economy in early upshifts shams13 Tech Help 11 12-09-2004 02:52 PM
Fuel economy 300SDL bhatt Tech Help 1 06-25-2004 12:24 PM
190E Fuel economy???? 190ESport Tech Help 10 02-24-2004 04:06 PM
A road trip and some questions about economy R Leo Diesel Discussion 10 04-02-2003 02:27 PM

All times are GMT -4. The time now is 02:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page