Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-07-2001, 06:12 PM
420benz's Avatar
Registered User
Join Date: Jul 2001
Posts: 951
Idel problem

When engine is hot the idle increses and decreases every 3 to 4 seconds. This happens with the a/c on or off.Sorry this is an 89 420 sel.Car has all new plugs and wires. Any suggestions?
Reply With Quote
Old 12-07-2001, 10:20 PM
Registered User
Join Date: Dec 2000
Posts: 368
I am assuming that it runs fine when the engine is cold. It sounds like a fuel problem. Start by checking the fuel accumulator.

Reply With Quote
Old 12-08-2001, 04:35 AM
dpetryk's Avatar
Electrons can do anything
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
I am having the same problem. It seems to be the throttle body switch. I know that my switch is not making good contact when the throttle is in the idle position. When the contact opens, the idle controller stops regulating the idle speed and it creeps up. Then due to vibration or some other phenonemon, the switch makes contact and the idle controller regulates the idle properly. If I quickly press the gas pedal and quickly release the idle returns to normal, sometimes, or not.

You can check by using an ohm meter to measure the resistance of the contacts. The plug for this switch is located just under a PCV hose very close to the cold start injector valve. Move the hose and unplug the connector. There are three wires. Center is common and the one contact is made then the throttle is fully closed, and the other when the throttle is fully open. Make sure that you get a good steady low resistance reading at each throttle position.

If thats not it you might have problems with the idle control valve. Its that cylinder shaped device just to the left of center on the top of the engine. It vibrates when the engine runs. They get gunked up with goo and need a cleaning from time to time. I would put money on the switch if I were a betting man.

Good luck. Let me know what you find.
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote
Old 12-08-2001, 09:10 AM
420benz's Avatar
Registered User
Join Date: Jul 2001
Posts: 951
idel problem

VINAMG Where is the fuel accumulator and what does it look like?DPETRYK I will check the throttle body switch today thanks guys.
Reply With Quote
Old 12-08-2001, 03:38 PM
Registered User
Join Date: Dec 2000
Posts: 368
It's attached next to the fuel pumps, rear passenger side. Run the car for a while. Then disconnect small rubber hose on accumulator and check if any fuel comes out of the accumulator. If it does, you have a bad accumulator.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Very odd problem... harv190 Tech Help 3 11-06-2003 06:52 AM
Electrical Problem? 87300SDLTurbo Tech Help 0 10-23-2002 02:29 AM
Igniton switch or Relay Problem cmusante Tech Help 1 10-07-2002 06:00 PM
Paying Labor Cost to look for problem!!!! Aija Tech Help 4 07-20-2002 09:13 AM
Extreme idel problem with 73 450SL cdunne Tech Help 0 05-13-2002 03:32 PM

All times are GMT -4. The time now is 04:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page