Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2010, 07:47 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
My new project

Well my new project is almost the newest car I have ever bought LOL I am now the new owner of a 1990 Mercedes 300E 2.6. It's really a nice car, just has a lot of cleaning needed as well as a little pieces fixed up. The car will crank and not start, the PO had mention the neutral safety switch being a malfunctioning issue so I will start there. Chances are this will become the better halfs commuter to save $ on gas













Reply With Quote
  #2  
Old 07-18-2010, 09:47 PM
Registered User
 
Join Date: May 2009
Posts: 398
OVP, NSS, Coil, cap and rotor, wires. Start there you will probably find out whats causing the no start condition.
Reply With Quote
  #3  
Old 07-18-2010, 11:14 PM
Registered User
 
Join Date: May 2007
Location: New Jersey
Posts: 95
my car is a 94 w124 so I'm not sure if its exactly the same, but when my neutral safety switch was bad the car would not crank at all. I would turn the key and absolutely no noises like a completely dead battery
__________________
1994 E320, 145,000 miles
Reply With Quote
  #4  
Old 07-18-2010, 11:15 PM
cth350's Avatar
Registered User
 
Join Date: Dec 2000
Location: Long Island, NY
Posts: 3,840
Neutral safety switch will keep it from cranking. Definitely do some quick checks of the ignition and fuel delivery.

If you have a timing light, the fastest check is to clamp it to the primary wire on the distributor and see if you get a steady stream of flashes or if it's skipping a few beats.

Have an assistant listen for a hum from the fuel pump when the key is first turned (it's by the back wheels) to get a quick feeling for fuel delivery.

Then start tracking down current flow and/or replacing parts in whichever system is the most non-functional.

Won't hurt to find a pick-n-pull that can supply a few key relays and modules. Nor would it hurt for you to research those terms used in macdrone's post.

-CTH
Reply With Quote
  #5  
Old 07-19-2010, 11:02 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Well I went under the car and the NSS was a wiring mess... I cleaned it up and all works now. WOO HOOO!!! My guess was crossed wires and exposed connections (To rain and such) Car drives great on the freeway, a little bit of a rough idle but nod bad overall. I have started to make a list of what is needed!
Reply With Quote
  #6  
Old 07-19-2010, 11:33 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Well Day 2 of playing around with the new ride. Got home after work an pulled it in the garage to start getting a list of items needed. I ended up cleaning up wiring, reattaching a bunch of little items, finding places that need attention. I also did a quick clean on it to see just how bad it really is. After finding a couple dollars change, a ring, some fireworks and many other odd and gross things she cleans up nicely. I will do a full detail after I get the mechanical items all worked out. However most of what was wrong so far has been an easy fix and just loose or disconnected items. While there is a long way to go I have high hopes for this car! Now on to the pics.... And yes I had to take the side by side with the other Benz haha




While cleaning







Some more pics




Here is a before and after of the door... Any tips for cleaning duct tape? there is some left and I am all ears
Before


After
Reply With Quote
  #7  
Old 07-20-2010, 02:27 AM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
May I please ask how much was the purchase price of the car?
Regards, Eric
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.
Reply With Quote
  #8  
Old 07-20-2010, 02:53 AM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Does the horn work? Whatever hit the grill may have taken it out...Can't tell by the pictures. What about the condenser? Whatever hit the grill to damage it must have been pretty heavy...

Looks like a great project though. Biggest thing I see is the ding in the rear trunk lid...Bumpers and grill are easy to find.
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #9  
Old 07-21-2010, 11:51 AM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Quote:
Originally Posted by ps2cho View Post
Does the horn work? Whatever hit the grill may have taken it out...Can't tell by the pictures. What about the condenser? Whatever hit the grill to damage it must have been pretty heavy...

Looks like a great project though. Biggest thing I see is the ding in the rear trunk lid...Bumpers and grill are easy to find.
Horn works fine, however the driver side electric fan now hits some screw heads and wobbles. Will need to replace that. The AC didn't work before the wreck, but there is no damage to the condenser.

Where is a good place to find the grill and such? the yards here seem to be out of the E class.
Reply With Quote
  #10  
Old 07-21-2010, 12:05 PM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,187
My friend here in Wichita, KS has a salvage yard with about 10 W124s and could get it to you cheaply enough.

google
Euroasian Auto Wichita

I have the headlamp assembly; its yours for $30 shipped.
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
  #11  
Old 07-21-2010, 12:09 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,631
Quote:
Originally Posted by Colorado220 View Post
Horn works fine, however the driver side electric fan now hits some screw heads and wobbles. Will need to replace that. The AC didn't work before the wreck, but there is no damage to the condenser.

Where is a good place to find the grill and such? the yards here seem to be out of the E class.
i have a nice e class grille 86-92 with the 500e black inserts...looks nice
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #12  
Old 07-21-2010, 12:46 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Quote:
Originally Posted by TylerH860 View Post
My friend here in Wichita, KS has a salvage yard with about 10 W124s and could get it to you cheaply enough.

google
Euroasian Auto Wichita

I have the headlamp assembly; its yours for $30 shipped.
PM on the way!
Reply With Quote
  #13  
Old 07-21-2010, 12:55 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Quote:
Originally Posted by lee polowczuk View Post
i have a nice e class grille 86-92 with the 500e black inserts...looks nice
email sent
Reply With Quote
  #14  
Old 07-21-2010, 11:00 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Well I went and pulled the cluster out, the gear had walked out like many others here. I pused that back in and the ODO/Trip now work WOO HOO!!! But now the ABS light is on... Wasn't before.... I took it all back apart and traced the wires and such. Nothing was pinched or poked.. guess the problem just came at that time... Oh joy




Reply With Quote
  #15  
Old 07-21-2010, 11:55 PM
Colorado220's Avatar
Registered User
 
Join Date: Dec 2006
Location: COLORADO
Posts: 631
Quote:
Originally Posted by macdrone View Post
OVP, NSS, Coil, cap and rotor, wires. Start there you will probably find out whats causing the no start condition.

What does OVP mean?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page