Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-17-2001, 10:36 AM
Inky Winky
Posts: n/a
Question Bouncing Idle when car is on "P"

Hello everyone,
Last week my car (1995 C-280) began to give me problems:
1. When I turn the car on the idle bounces anywhere from 4-14 RPM. When I put it on "D" everything is fine, however, when I come to a stop, the idle goes down and back up (it does this with and without the a/c).
2. When I step on the gas, the car waits about 2 seconds to respond, then it mis fires and finally accelerates poorly.
Both of these problems began at the same time. Any help will begreatly appreciated. Thanks in advance.
Reply With Quote
Old 12-17-2001, 03:05 PM
Inky Winky
Posts: n/a
Could it be fuel pressure? or air meter? NOTE: the "check engine" light is NOT on!
Reply With Quote
Old 03-25-2002, 11:58 PM
Posts: n/a
Usually, this osrt of thing can be traced to a vacuum leak.
The idle stabilizer circuit is going outside of its parameters attemting to maintain your idle.
Check out all air hoses and clamps and even things like the dipstick, oil filler cap, and vacuum lines.
After you have determined that *no* air leaks are present,
then you check any fuel pressure regulating functions, and temperature sensors.
Reply With Quote
Old 03-26-2002, 12:57 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Sounds like the MAF (Mass Air Flow) sensor. MAF failure is a common failure on the M104 engines... sounds like this is probably your problem.

It does not bounce in D, but only in P, correct? Test Neutral, it should bounce in that too, I believe. The MAF is the wire connector that attaches to the air intake between the engine block and the air filter.

You can try twisting/unplugging the sensor with the car in Park and see if it makes a difference...

Good luck!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 03-26-2002, 10:15 AM
Inky Winky
Posts: n/a
Thanks for the replies. Although it's been a long time I still have the problem. I will check the vaccum line as well as the air sensor. How can I know if it is the air sensor?
Reply With Quote
Old 03-26-2002, 10:21 AM
Registered User
Join Date: Jul 2001
Location: Western Michigan
Posts: 1,080
Mass Airflow Sensor will probably trig a "check engine" light.
Reply With Quote
Old 03-26-2002, 10:28 AM
Inky Winky
Posts: n/a
Ok. Let me clarify... The "check engine" light is NOT on. Basically the problem is when I accelerate the car. When I accelerate fast the car does not respond quick and misfires several times. However, if I accelerate very slowly everything is fine.
Reply With Quote
Old 03-26-2002, 11:31 AM
Registered User
Join Date: Sep 1999
Location: Toronto, Ontario
Posts: 210
I'm getting the same thing but my check engine light is on. p0170 is the reading. I know it could be the MAS and stuff...I'm just trying to make sense of the live reading i'm getting to make sure that it is.
1997 Silver AMG C36
OEM Advantegarde Grille
OEM Clear Corners
W210 Blinking mirrors
Eibach/Bilstein Combo
Zender Rear Lip Spoiler
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
380SL Idle Problem Kevin_300CE Tech Help 4 08-02-2007 05:50 PM
Took our'67 to first car show 68_Mercedes Vintage Mercedes 16 11-23-2004 04:01 PM
ICV-what's it for? and can high idle hurt trans? gmercoleza Tech Help 10 11-18-2004 10:16 PM
Idle question after rebuilding cylinderhead Meza Tech Help 4 12-28-2003 09:54 AM
1986 300E--hesitation at idle edbardzik Tech Help 7 06-03-2000 06:47 PM

All times are GMT -4. The time now is 06:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page