Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-09-2002, 02:55 PM
bermuda
Guest
 
Posts: n/a
Rough idle @ economy guage not working 420 SEL

I lent my 1988 420 SEL to my father inlaw and when I got the car back the idle was rough. He had filled the car with gas so my first thought was bad gas. I have already run Three quarters of a tank of new gas through the car and it is still idling rough. I also noticed that the economy gauge had stopped working. Could a vacuum leak cause a rough idle?

Thanks

Dave Schwartz
Reply With Quote
  #2  
Old 01-09-2002, 03:31 PM
natsman
Guest
 
Posts: n/a
Most certainly.......
Reply With Quote
  #3  
Old 01-09-2002, 03:34 PM
Registered User
 
Join Date: Jun 2000
Location: Tucson, Arizona, USA
Posts: 180
Absolutely! and you can start your search from the line for the Economy gauge. A hand-held vacuum pump and digital multimeter are the most valuable tools I have for my MBs. Look in the manuals on the W126 CD-ROMs--there are good vacuum diagrams there. Cheers, Andrew Seidel.
__________________
86 560SEC
85 500SEC Lorinser
83 300D Turbo
75 240D
Reply With Quote
  #4  
Old 01-09-2002, 05:09 PM
dpetryk's Avatar
Electrons can do anything
 
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
Ok here are some things to check. You will find a small vacuum line running from the back of the engine to a small rubber "Y" connection just in front of the fuse box. It is usually strapped to the large black vacuum line going to the brake booster. One of the connections goes to a yellow vacuum check valve that has 3 connections on it. One of these connections (on the Y connector) goes to the line leading to the economy guage. Check these vacuum circuits carefully. I have seen the Y connector get hard, start leaking and generally fail. This would cause a vacuum leak and affect the mixture of the engine. Also check the vacuum connection on the back side of the engine for leaks or broken parts.
__________________
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cold rough idle 420 SEL 89 Marcelb Tech Help 8 10-31-2003 02:05 AM
560 SEL Rough Idle (Another one!) hbofinger Tech Help 48 06-25-2002 02:24 PM
Idle adjust on 87' 420 SEL Bob U Tech Help 7 06-10-2002 02:05 AM
Lumpy Idle 420 sel jsomerv Tech Help 2 01-18-2002 04:54 PM
1988 420 SEL Cruise Control not working bermuda Tech Help 1 04-08-2001 05:43 PM



All times are GMT -4. The time now is 11:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page