Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-27-2002, 10:13 PM
Posts: n/a
Question 1987 300E Running Problems

I drove my car '87 300E to work the other day and it ran fine. When leaving work that same evening it would not start. It seemed like it wasn't getting fuel or a spark. Upon removing the coil wire from the dist. cap I noticed the cap was severely burnt. I replaced the rotor, dist. cap and the spark plugs. No I can get the car started but it stalls when in gear or from not having my foot on the gas. If I do get the car moving I am afriad to move into traffic because it sputters and/or dies. If I am lucky enough to get past the sputtering and up to speed the car runs fine but when I get back near idle I repeat this problem.

I recently purchased this car because it was extremely clean with low miles for a 1987 but have had to replace several parts (radiator, water pump, alternator, engine/trans. mounts, and some front suspension parts) that I knew I would have to replace eventually just not in the few months that I have had the car. I am hoping that I have replaced most of the normal wear and tear parts and will have some time between visits to the shop.

Any suggestions/comments on this model or my problem, good or bad, would be greatly appreciated.

Reply With Quote
Old 01-29-2002, 02:22 AM
Registered User
Join Date: Dec 2000
Location: SF Bay Area
Posts: 115
I had a similar problem with my '88. Replaced the OVP relay and it idled once again.

'88 300E 265K
'91 300TE 155K
Reply With Quote
Old 01-29-2002, 05:50 AM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Exclamation I agree!

Sounds like is time for a new OVP, very common problem. Around $50. Do a search, it has been discussed before.
'86 300E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300E Cold starting problems... (-88) Sundman Tech Help 28 03-23-2004 10:35 AM
selling my 1987 300E CHEAP! Mateo Mercedes Cars For Sale 2 11-17-2003 09:17 PM
1987 300E or 1981 300SD - considering buying- need advice 86560SEL Diesel Discussion 1 10-13-2003 02:05 AM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 12:14 PM
need info on 1987 300E Tigger300E Tech Help 2 03-29-2002 08:51 PM

All times are GMT -4. The time now is 10:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page