Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2002, 04:31 PM
Registered User
 
Join Date: Apr 2001
Location: Sheboygan, Wi.
Posts: 16
Question 87 300E clogged fuel filter?

My well maintained trouble free car has come up with a bug.
I noticed it yesterday for the first time ever. Basically I am getting greatly reduced response from the accelerator pedal. At one point from a standing stop I almost floored the car and it was barely moving, and the economy guage was buried in the red, then power starts coming back, but it feels very restricted and held back. It may also have a slightly rough idle that was not there before. The air filter was new last week.One possible thing that was different in the last day is we got a bunch of snow, and the car was confined in the garage overnight with lots of moisture from melting snow? Then I thought there might be something with the transmission because there is a slow leak, which I am vigilant about. I test drove the car for 10+ miles to warm it up then checked the trans level. It was perfect. Im thinking now maybe a fuel filter.
Can anyone here relate these symptoms to a clogged filter, or some other component/system that would cause this?
I have put 45k on the car since buying, without any new fuel filter.
Thanks in advance for all your help!

Greg Stein
1987 300E, 205K
1979 280CE, ???K
Reply With Quote
  #2  
Old 02-01-2002, 05:47 PM
Michael's Avatar
Veteran
 
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Your car has a large fuel filter-given the relative quality of fuel today, it should last 100k miles easy! Heck, if you buy a new Honda Accord, it has a similarly-sized fuel filter which is expected to last the life of the car! Then again, a Honda Accord usually dies because its body falls off

I suppose if you don't know the age of the filter, replace it. I'd also replace your gas cap, as it should seal perfectly and eliminate any concerns regarding moisture being absorbed that way.

Good luck
__________________
"If everything seems under control, you're simply not going fast enough" --Mario Andretti

Michael
1995 E500 street car
1986 Porsche 944 Turbo S track car
Reply With Quote
  #3  
Old 02-01-2002, 09:52 PM
Registered User
 
Join Date: Nov 2001
Posts: 53
Ya might wanna check out all ignition wires/connections, I am by NO means an expert, but that is where I would look first.

donn
__________________
1990 300E (118K)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixed my fuel gauge - 300E! Zeus Tech Help 6 02-20-2004 03:58 AM
diesel leaking at/under fuel filter? edge Diesel Discussion 14 12-01-2003 09:31 PM
300DT '87 won't start after fuel filter change danarubison Tech Help 3 11-30-2003 10:20 PM
Sticky Fuel Distributor in 1987 300E Walter Ebner Tech Help 3 07-02-2003 01:21 PM
300E Fuel Pumps and Filter Leaking EstebanSPI Tech Help 8 06-22-2002 07:12 PM



All times are GMT -4. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page