Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-05-2002, 01:48 PM
Posts: n/a
Serious Tech Help Needed

Hey Guy's,
I could really use some help from you MBZ Techs.

I have been reading and looking for answers and am very confused.
I was just going to replace my transmission, but figured if I could save that expense, the money could be used for other "goodies" for the car. Here's my problem, I had my trans serviced about 4k ago, filter, fluid, and modulator. I took it on about a 100mi ride on the turnpike, got off and when i came up to a light it started to slip in first gear, but only if i got into the pedal, if i slowly accelerate it is fine and shifts thru the rest of the gears fine.
Does this sound like it is shot? Every place i have called says it needs a rebuild, but im not convinced yet given what i've read in the forums. Maybe the B-1 piston?, modulator adjustment?, other type of adjustment?
Slips only in 1st, but always shifts fine thru the rest of the gears.

Please help before i spend 1500.00 on something that could have been fixed.
Reply With Quote
Old 02-05-2002, 03:10 PM
Posts: n/a
Slipping trans

If it only slips in first gear it is probably related to B-2 or the valve body.
Remove the rear piston cover on the right side back of the trans.(to do this push the cover in and pry out the lock ring) pull out the piston and see if it has cracked or broken.
If it is broken just replace it with a new one,if not reinstall it making sure the thrust pin is installed correctly,then consider a used or recond. trans.
Reply With Quote
Old 02-05-2002, 05:05 PM
Posts: n/a
Reply With Quote
Old 02-06-2002, 01:27 PM
Posts: n/a
Thanks for the reply Mike.
I'll try to look at it this weekend.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Meguiars NXT Tech Clinic February '04 placo1 Events & Gatherings 24 02-09-2004 05:43 PM
Possible Diff swap in 95 E320 - Tech help needed JetForeman Tech Help 2 10-31-2003 12:24 PM
Did Tech over fill my A/C 134a? Johne 320 Tech Help 6 08-11-2003 09:52 PM
Tech changed plugs -- now it runs rough. brookspw Tech Help 11 08-07-2003 05:44 PM
3 problems with my E420, need tech advice. Subman Tech Help 0 05-23-2002 04:58 PM

All times are GMT -4. The time now is 11:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page