Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2002, 09:57 PM
toyberg
Guest
 
Posts: n/a
Angry 94 E320 Hard Starting

My 1994 E320 has a hard starting issue. I have had it to a mechanic who at the time said he could not diagnose the problem until the main wiring harness was replaced (was there a recall on this?) Anyway, he rebuilt my fuel pump because the line pressure was not up to spec. He then kept the car overnight with a gauge on the fuel line and said the pressure dropped overnight. At the time I didn't have the $750 to replace the wiring harness and have just recently had it done. The problem still persists, and I'd like to avoid another costly repair as the car has 138,000 miles on it. FYI, I already replaced the Overvolt Protection Relay.

BTW, The car starts after 5-10 sec with my foot on the gas. After a few revs it settles in at about 600Rpm idle. It stalls intermittenly if I run the A/C in stop and go traffic or at idle in drive.

Any ideas on what to look at?
Reply With Quote
  #2  
Old 02-12-2002, 10:33 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Three big issues on these to check.
1. Fuel pressure regulator.
2. Throttle actuator.
3. Fuel injectors.

Your tech should look at these as well as other issues.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 02-13-2002, 02:13 AM
biggs81
Guest
 
Posts: n/a
Definitly have your Fuel accumulator checked. That could be the cause of hard starting and lose of fuel presure. Its located between the rear axle and the gas tank. If you take the little rubber hose off and it spills gas then you have a bad accumulator. Good luck with your MB...

-Biggs
Reply With Quote
  #4  
Old 02-28-2002, 04:15 PM
mbe32094's Avatar
Registered User
 
Join Date: Feb 2002
Location: Bay area, CA
Posts: 107
For the time being to avoid all these checks.
Everytime you start your car. Turn your ignition switch to ignition. Wait for about 5 to 10 seconds to build up fuel pressure. Then crank your engine. Don't press on the gas pedal. Boom your car starts. I have this problem with my 94E320. If your are not in a hurry to leave you can live with it for now.
Reply With Quote
  #5  
Old 02-28-2002, 07:55 PM
toyberg
Guest
 
Posts: n/a
Looks like the throttle Acuator

Mechanic says this is the problem and of course the most expensive. Part alone is $900. Argghhh.

First and last Mercedes experience. Going back to my reliable and much less expensive to maintain BMW
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 300 CE Hard Starting Problem sonny906 Tech Help 0 06-27-2003 10:04 PM
86' 300E hard starting when cold JFAZ Tech Help 8 10-17-2002 04:53 PM
Hard Starting Solved 94 E320 mbe32094 Tech Help 3 09-21-2002 10:55 PM
Advice RE hard to find bulbs on W210 (E320, E430 1996 and newer) aTOMic Tech Help 0 08-26-2002 10:44 AM
Hard starting..the new chapter. atk_man Diesel Discussion 4 03-28-2002 04:30 PM



All times are GMT -4. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page