Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2012, 02:44 PM
stormyc88's Avatar
muffled but untamed
 
Join Date: Oct 2010
Location: Babylon, NY
Posts: 160
M103 1500 rpm idle: icv??

Hey all,

I have experienced the very first running problem with my 87 300e this morning. Started up, idled great and cruised great on the 20-mile drive to work, like it always does. Stopped at dunkin donuts, and when I got back in and restarted it, the idle stayed at 1500 rpm. Run quality at that and all other speeds is just fine, as is throttle response. Would this be caused by the idle control motor? Any input would be greatly appreciated. Also, how hard of a job is it to change that? Big job?

Thanks!
-Chris
__________________
Streetside: 1987 Mercedes 300E Petrol Blue/Green
2014 Ford Mustang Grabber Blue
1999 Ford Ranger Green

Dockside: 1968 Eltro 17
1985 Silverton 34C
Reply With Quote
  #2  
Old 08-17-2012, 03:21 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,469
Two bolts hold it down. Pull it off and shoot carb cleaner through it to make sure there is no debris or dirt jamming it open.

Also inspect or replace the idle control hoses that are attached to it if they are rock hard.
__________________
W124-Zone.com
2008 Black Mercedes E350 4Matic Sport P1
1988 Pearl Grey Metallic Mercedes 300TE - 186k
2014 Jeep Wranger Unlimited Sahara - 50k
http://www.w124-zone.com/downloads/p...desig300te.jpg.http://www.w124-zone.com/downloads/p...50/e350sig.jpg
Reply With Quote
  #3  
Old 08-17-2012, 04:10 PM
Registered User
 
Join Date: Sep 2009
Location: San Diego
Posts: 16
Ck the WOT switch, small switch w/ roller activated by the throttle linkage. If you unplug it and idle returns to normal you've found your problem.
Reply With Quote
  #4  
Old 08-17-2012, 09:59 PM
stormyc88's Avatar
muffled but untamed
 
Join Date: Oct 2010
Location: Babylon, NY
Posts: 160
Thanks for the input!

removed the icv and cleaned it, it was quite dirty inside.

checked the hoses and they feel fine, not hard or crumbly or anything.

Put everything back together and it idled normally, so..

is this it?? should I replace anything as preventative maintenance? or just leave it alone and see if it happens again and worry about it then?
__________________
Streetside: 1987 Mercedes 300E Petrol Blue/Green
2014 Ford Mustang Grabber Blue
1999 Ford Ranger Green

Dockside: 1968 Eltro 17
1985 Silverton 34C
Reply With Quote
  #5  
Old 08-18-2012, 02:20 AM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,469
You should do a normal standard tune up if you have no history of each individually.
Plugs, wires, rotor and cap and all fluids and filters. Other than that, leave everything as-is unless there is something wrong.
__________________
W124-Zone.com
2008 Black Mercedes E350 4Matic Sport P1
1988 Pearl Grey Metallic Mercedes 300TE - 186k
2014 Jeep Wranger Unlimited Sahara - 50k
http://www.w124-zone.com/downloads/p...desig300te.jpg.http://www.w124-zone.com/downloads/p...50/e350sig.jpg
Reply With Quote
  #6  
Old 08-20-2012, 04:19 AM
Registered User
 
Join Date: Jun 2011
Location: Tottridge,London
Posts: 193
In addition to above new fuses will save many a intermittent problem.
Ad
Reply With Quote
  #7  
Old 08-20-2012, 03:10 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 4,987
If the throttle microswitch is not being actuated while the linkage is in the idle position..the m103 will idle at 1500 rpm. just something to keep in mind.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page