Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2002, 12:02 AM
bimmerboy
Guest
 
Posts: n/a
Unhappy dead miss at idle speed

I need help! I have a 1992 190e 2.3 8v with a serious miss at idle speed. The car has 202k miles. When the car is cold, it idles great for 20 seconds. After that, it's like the choke turns off. I guess the cold start injector turns off. This is when it starts missing. It's very sluggish at low RPM's. It is also getting very bad gas milage, like 10mpg. It black smokes at idle and on take off. I've talked to several mechanics over the passed 3 months. I've even used some of this sites suggestions to no avail. I have checked fuel pressure and compression. I've checked the timing chain for slack and valve adjustment. I've replaced plugs, wires, fuel pressure reg, dis-cap, rotor, fuel injectors, all 4, O2 sensor, CIS temp sensor, thermo-vac switch. None of the suggestions have had any affect on this problem. please help?



1990 Montero 150k
1992 190E 202k
1997 BMW 328i 51k

Last edited by bimmerboy; 02-26-2002 at 12:12 AM.
Reply With Quote
  #2  
Old 02-26-2002, 09:08 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Chcek your EHA current and/or differential pressure.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 02-27-2002, 01:47 PM
bimmerboy
Guest
 
Posts: n/a
Thanks Steve. I found your write-up on "Evaluating Electronic Engine Controls" on this site. I'm going to give that a try this weekend. I'll let you how it goes. By-the-way, I know by reading my forum that it looks like I'm just a "Parts Replacer",but it's just that I don't have access to any trouble shooting tools. I do although have a book on the basic CIS fuel injection systems.
Thanks again, Greg
1990 Montero 151k
1992 190E 202k
1997 328i 50k
Reply With Quote
  #4  
Old 02-27-2002, 08:35 PM
bimmerboy
Guest
 
Posts: n/a
Steve, I borrowed a FLUKE 87 meter but I'm not quite sure where to check the EHA or Differential pressure so here goes. The connector, a two pin, on the firewall side of the fuel distributor has a reading of 41.5 with the key on and engine off. The connector, a three pin, on the radiator side of the f/d has a reading of 46.5 with key on and engine off. So what does this mean? HELP! Also where is the OVR located? Thanks Greg.
1990 Montero 151k
1992 190E 202k
1997 328i 50k

Last edited by bimmerboy; 02-27-2002 at 08:47 PM.
Reply With Quote
  #5  
Old 02-28-2002, 01:15 PM
bimmerboy
Guest
 
Posts: n/a
Steve, there was no change at all when I unpluged the two pin connector on the back of the fuel distributor. I'm still assuming that this is the EHA.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
high idle speed M110 280 G-Man Tech Help 4 01-13-2004 09:33 AM
Idle Speed - 1985 500 SEC awfrance Tech Help 10 01-31-2003 05:30 PM
OM603 Idle Speed tomkanis Diesel Discussion 9 01-19-2003 01:52 AM
where is the idle speed control module located? aussie Tech Help 2 09-21-2001 08:52 AM
UNEVEN IDLE SPEED ON 124.032 MB STARS Tech Help 3 04-29-1999 09:15 PM



All times are GMT -4. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page