Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-27-2002, 03:15 AM
webrits
Guest
 
Posts: n/a
New 190E owner problems !!

Greetings all,

I'm the proud new owner of my first MB a 1989 190E w/89k.
Just a couple of questions.

Sunroof: Is it supposed to tilt as well as slide? If so, why doesn't it tilt? It doesn't even make a sound when I pull on the switch, but it slides great.......

Heat/AC control : There doesn't seem to be much control over the temp of the AC. It seems to be COLD even when I turn the control to the white portion of the dial. Is this normal? If not, any idea what the problem is? I was thinking it could be some sort of rheostat problem.

Antenna : The switch does nothing and the motor doesn't seem to make a sound. Is there a fuse just for the antenna? Or does the motor give up all together?

Trunk Locking : The central locking works fine except it doesn't operate the trunk. The only way to open the trunk is to insert the key, turn 90 to the left and press the button in. To lock turn back to vertical and remove the key. Is this normal of vacuum leaks or actuator problems?

Thanks for any help, sorry about the loooong post.
If anyone can recommend a shop manual (and where to buy) I'll get cracking as soon as poss.

Thanks again,

Paul
Reply With Quote
  #2  
Old 02-27-2002, 10:19 AM
Registered User
 
Join Date: Apr 2001
Location: Indianapolis
Posts: 87
Paul: On the sunroof, to get it to tilt, PUSH the switch straight up. To close it from the tilt position, PULL the switch down as you have described. As for the Antenna, do a search on this site, there is all kind of information on the Hirshman antennas. Good luck and enjoy the Benz.
__________________
Eric
'88 300E
'00 Expedition
'86 Alfa Romeo Spider
'84 Harley Davidson FLH"X"
Special Edition
'70 FJ40 Land Cruiser (basket case)
Reply With Quote
  #3  
Old 02-28-2002, 11:12 AM
webrits
Guest
 
Posts: n/a
Jesus.... how easy was that !
Don't I feel like an idiot

Thanks E!
Reply With Quote
  #4  
Old 02-28-2002, 11:50 AM
thebern's Avatar
Registered User
 
Join Date: Jan 2002
Location: Knotts Island, NC
Posts: 382
Feeling stupid

Paul,
Get used to it! We all have asked questions that are so important to us, yet are so easy for others. This is why the forum is so great. While we/they may give you easy solutions, others aren't so easy. We will mess with you, but at the same time provide you with first hand knowlege. I know, as some of my posts have been returned in 10 minutes.

Congratulations on your first Benz, I don't think you will ever want anything again other than a Benz.

Bernie
__________________
1982 240D 313,000 (4 speed)
1984 300CD 172,483
1985 German Shepherd Dog -Lacey- R.I.P.11/04/05

Hood Stars, Wrist Crowns and Obsession Dobs
Reply With Quote
  #5  
Old 02-28-2002, 12:22 PM
Registered User
 
Join Date: Apr 2001
Location: Indianapolis
Posts: 87
Paul: Don't feel like an idiot...that is what this forum is for, to ask questions that you don't have the answer to. It's all a learning process. I was in your shoes a year ago...stay with the forum and you will learn all kinds of crazy *****!!
__________________
Eric
'88 300E
'00 Expedition
'86 Alfa Romeo Spider
'84 Harley Davidson FLH"X"
Special Edition
'70 FJ40 Land Cruiser (basket case)
Reply With Quote
  #6  
Old 02-28-2002, 01:54 PM
Registered User
 
Join Date: Jun 2000
Location: Saugus, CA USA
Posts: 1,989
My trunk lock does kind of the same thing sometimes, except the central locking does work on it. I've lubed the lock and that seems to have helped it. My suggestion is to read the manual about locks and valet locking, thats an obscure thing it does.
__________________
5 speed '91 190E 2.6 320,000 mi. (new car, fast, smooth as silk six, couldn't find any more Peugeots)
5 speed '85 Peugeot 505 2.5l Turbo Diesel 266,000 mi. (old car, fast for a diesel, had 2 others)
5 speed '01 Jetta V6 (new wifes car, pretty quick)
5 speed '85 Peugeot 505 2.2l Turbo Gas 197,000 mi. (wifes car, faster, sadly gone just short of 200k )
5 speed '83 Yamaha 750 Maxim 14,000 mi. (fastest)
0 speed 4' x 8' 1800 lb Harbor Freight utility trailer (only as fast as what's pulling it)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
87 190E 2.6 hard starting problems. Ralph Todd Tech Help 11 11-07-2008 10:25 PM
190E Idle problems, fuel overload.. Charl190e Tech Help 11 10-23-2004 12:39 PM
New 300TD owner...couple problems 300TDinDC Diesel Discussion 6 09-22-2004 10:04 PM
2.3 190E 8V Problems richbark Tech Help 4 02-11-2002 12:27 PM
190E 16V Computer/Sensor Problems SCBauman Tech Help 6 06-08-2001 09:31 PM



All times are GMT -4. The time now is 07:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page