Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-08-2002, 03:33 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
C230's first component failure...

Well, at about 80K and a year and a half ago, I had the final drive seals replaced under warranty, but only one seal was sweating, and so slightly it was really tough to tell. The dealer replaced them to avoid a ***** session with me. So, i'm not counting that warranty repair.

Today, I had my first REAL failure. This morning, my blower fan was squealing like Ned Beatty in Deliverance, and REALLY horribly around right hand bends.

A quick trip to the dealer, and they lubed the bearings, but two blocks away, it came back, just as bad. New one will be in on Tuesday, replacement under warranty.

Anyone who has replaced a W124 blower fan would faint at how easy it is on the W202 C-Class! I could do it myself. (Would were the car out of warranty)

Anyone know if the evaporator is that easy too? Wouldn't that just make long term ownership TOO easy?

I'm not surprised at the failure. Our cold dry winters are murder on the blower fans, and MB's seem pretty failure prone anyway. All my 190E's had them on my list of "about to go anyday" components.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pump Or Bearing Failure - Is This A Valid Way To Diagnose? ezrider Diesel Discussion 10 03-13-2004 10:55 PM
odd CC mode of failure delucat2 Tech Help 0 10-16-2003 02:34 PM
Help to diagnose exterior light failure indicator on 87 W126. ivorysdl Tech Help 0 02-19-2003 10:30 PM
Bearing failure on spindle due to lost bearing grease-how do I repair? 85 300D Carrameow Tech Help 5 09-17-2002 02:14 PM
component systems jmagbita Car Audio and Multimedia 0 08-18-2002 12:40 AM



All times are GMT -4. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page