Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-18-2002, 12:02 AM
Posts: n/a
1983 3000 SD Battery

I have an 83 300 SD and the battery seems to be dead. Once I turned the car off the fan kept going and slowly died. When I tried jumping the car the fan turned on again but the car still did not start. Does this seem like the battery needs to be replaced?

Also, is the battery easy to remove?

Reply With Quote
Old 03-18-2002, 09:28 AM
Posts: n/a
This is the procedure:
1) disconnect the positive terminal from the battery.
2) put a 2 amp charger on the battery for 24 hours or put a 10 amp charger on it for 5 hours.
3) let the battery sit for 12 hours after charging making sure to leave the positive terminal off.
4) get a digital volt meter and check the voltage on the battery - if it is less than 12.65 volts - replace the battery.
5) if it is 10.5-11.5 volts - you probably have a shorted or dead cell - replace the battery.
6) Do not run the car with a bad battery as it can put undue strain on the alternator.
7) If the battery results in #4 above is 12.65 volts or higher -(which I doubt) - reconnect the positive terminal and start the car. The voltage on the battery with car running should be 13.5-14.7 volts. If it is not - then you have a bad alternator or brush pack in the alternator.
Hope this takes the mystery out for you.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
intermitent dead battery ("+*#!) MarkM Diesel Discussion 7 12-17-2004 08:11 AM
Interstate battery fitment problem in '95 E420 DuckMuck Tech Help 18 11-05-2003 01:37 AM
"Maintenance Free" battery 99E300 steve hutson Diesel Discussion 11 12-20-2002 04:07 PM
Battery Venting Cloud Of Hot Acid TOM CONWAY Tech Help 2 11-03-2002 07:04 PM
1983 380SL A/C ran hot with faulty battery tnewman SL Forum 1 07-10-2001 11:17 AM

All times are GMT -4. The time now is 08:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page