Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-22-2002, 08:33 AM
Registered User
Join Date: Nov 2001
Location: Miami, FL
Posts: 70
Question Pulling, Shaking, Wandering.... then fine. Huh?

Ok.... I'm at my wits end. My '97 C280 has developed a transient shaking in the steering wheel. One day I'll go 60-80 mph, car drives straight and true, but with slight shake in the steering wheel. Then the next day, 60-80 mph the car will randomly pull hard to the right, steering wheel vibrates, then mysteriously vansihes. I can hold the wheel perfectly level, on a level road, and the car will wander off in one direction or the other - sometimes the steering wheel vibrates, sometimes not. So - I took it to my independent mechanic - he's says the lower control arm bushings are cracked. He checked the brakes, shocks, wheel bearings, etc. - all are ok except the bushings. He fixes them, the car drives fine until a few days later. Same problem appears except now it's worse. Sometime's there's slop in the wheel and the car doesn't feel tight at all. Then it's fine. Now, the random pulling and wandering happens at various speeds. My mechanic is at a loss. One other thing - there is a slight "rubbing" sound when I turn the steering wheel either direction - almost like a squeeky door. It's faint, but there.

Any thoughts?

Thanks in advance!

Ft. Lauderdale
Mark E.
Miami, FL
2 X 1997 C280
Reply With Quote
Old 03-22-2002, 09:15 AM
Posts: n/a
Rotate your front tires to the back. If the problem disappears - you probably have tread separation in a tire. As the tread shifts - you get these symptoms.
Reply With Quote
Old 04-23-2002, 01:14 AM
Registered User
Join Date: Jan 2002
Location: Colorado Springs, CO
Posts: 1,006
I should think cracked bushings get replaced. What is there to fix? My mechanic cut one of my front bushings out with a torch and hack-saw because it rusted in place from previous owner leaving in too long.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Runs fine...runs a lil rough...huh? ktang Diesel Discussion 1 12-26-2002 07:51 PM

All times are GMT -4. The time now is 03:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page