Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-22-2002, 01:02 PM
Posts: n/a
Unhappy Help With Heater on '95 E320?

The heater on my e-class started acting erratically and making weird "glass tinkling" and groaning noises. I checked the supplemental pump and it is drawing 960 millivolts, so based on previous posts here by Larry Bible I assume it is ok. However, I noticed that the shorter metal vertical canister in back of this little pump (a servo valve?) was getting extremely hot and I could feel the coolant flow thru the connecting heater hose surging like the a valve was shutting off and going on suddenly and repetedly. I unplugged the connector from this (valve?) unit. Is this a valve? Do they go bad in such a way? Is this my problem and if I replace it will my heater problems be solved, or is there a decent chance that this has also screwed up the electronics behind the dash? Thanks for any help!
Reply With Quote
Old 03-22-2002, 03:11 PM
Ali Al-Chalabi's Avatar
Senior Member
Join Date: Nov 2000
Location: Knoxville, TN
Posts: 1,837
The valve regulates the amount of coolant that flows through the heater core in order to regulate the temperature. Either the valve is faulty or it is recieving the incorrect signal. The fact that it keeps shutting off and on would lead me to believe that it is recieving an incorrect signal for some reason, but I do not have a great deal of experience with this. Hopefully someone else here can give you advice on how to further diagnose your problem.
Ali Al-Chalabi

2001 CLK55
1999 Dodge Ram 2500 Cummins Diesel
2002 Harley-Davidson Fatboy
Merlin Extralight w/ Campy Record
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
My worst nightmare - possible heater core leak ! yogiysh Vintage Mercedes 10 12-05-2004 11:23 PM
'94 E320 Heater only blows on right side vent edge Tech Help 5 11-15-2004 01:27 PM
Q: Replaced waterpump on '95 E321 W124 - broke vacuum line - heater not working 71Rcode Tech Help 3 10-11-2004 01:16 PM
97 E320 Heater blower stays on..key off Critical Bill Tech Help 10 01-08-2004 01:36 AM
Exploding Heater Cores? hill Open Discussion 3 06-03-2003 09:43 AM

All times are GMT -4. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page