Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-08-2002, 10:57 PM
ghj ghj is offline
Registered User
Join Date: Jun 2001
Posts: 16
speedo stopped working

speedo stopped working yesterday . The odometer works fine.What is the likely problem and solution.Cant seem to find it in my service cd.
Thanks; Georgey 300 td 1982
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Block Heater Stopped Working braverichard Diesel Discussion 23 12-05-2006 02:37 PM
Keyless Entry Stopped Working All of a Sudden babtahi Tech Help 1 10-14-2004 01:48 AM
w126 - all instruments stopped working daverdla Diesel Discussion 18 10-08-2004 12:57 AM
W140 Rear Sunshade stopped working... farena Tech Help 2 08-25-2003 09:26 PM
w126 blinker slowly stopped working dwcasey Tech Help 0 08-05-2002 11:16 AM

All times are GMT -4. The time now is 05:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page