Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-11-2014, 08:48 AM
Registered User
 
Join Date: Apr 2014
Posts: 7
W124 climate control 2 stage shut off

Hi Guys,

When I bought the car (88 300ce) I discovered that whole climate control system can malfunction in 2 ways:
1) Non of the 3 buttons work when you press them, lights in corner are out, full heat is on.
2) All buttons don't work but lights at corner are on, also full heat is on.


As soon I shut off the car and restart the car everything works again, aircon is cold, heat is how you set the wheels.

Any idea what can cause this kind of problem or what to check?

Regards,
Tom

Reply With Quote
  #2  
Old 05-11-2014, 10:44 AM
big dog 2's Avatar
ejgolfnten
 
Join Date: Feb 2005
Location: Elk Grove, Ca
Posts: 206
1. Check blower fuse under the hood. May look good but has hairline cracks. Replace it.
2. Climate control panel may be going south. About $25+ at Pic & Pull. Easy to replace.
3. In rare instances your ignition switch is bad. Bad contacts causes high resistance in blower circuit which frys the CCU circuit board.

All three happened to me!
__________________


1989 300E

2005 Acura TL

2011 Hyundai Elantra Limited

Swing hard! Take chances!
Reply With Quote
  #3  
Old 05-11-2014, 12:53 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
I recently worked on a 87 560SL's climate control system that was behaving similarly. It was stuck in full heat with high blower speed. No button presses changed anything.

Quite often what happens with these older electronics is that cold solder joints form, capacitors fail/leak out/go outside of tolerance and you end up with strange behaviours.

I've worked on a number of climate control system where this was true.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #4  
Old 05-15-2014, 07:50 AM
Registered User
 
Join Date: Apr 2014
Posts: 7
I have actually resoldered climate control panel, also climate relay (they looked good).
Also one strange thing for me, my climate control panel starts (if it starts) working after and only after car has warmed up, when thermostat opens.
Is this normal to W124 or there is another problem related to this?
Reply With Quote
  #5  
Old 05-15-2014, 09:07 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Quote:
Originally Posted by Tom300CE View Post
I have actually resoldered climate control panel, also climate relay (they looked good).
Also one strange thing for me, my climate control panel starts (if it starts) working after and only after car has warmed up, when thermostat opens.
Is this normal to W124 or there is another problem related to this?
Are you running the system in "auto" mode when this happens? In auto and heat I think it will wait until you have suitable coolant temp to make heat before turning on...

Did you replace any capacitors while you were in there? you might have some bad/dead ones in there that might be hindering operations.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #6  
Old 05-15-2014, 09:44 AM
Registered User
 
Join Date: Apr 2014
Posts: 7
I don't have auto option. I have climate control system with 3 buttons - Humidity, Snow and recirc.
Reply With Quote
  #7  
Old 05-15-2014, 10:10 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Hmm I've seen that style system in 190E's they had a manual fan speed slider.

It looked like this:

201 830 03 85 First Gen Climate Control W201 - Imgur

It had 3 stages of PCBs that needed resoldered/recapped.

Is that what yours kind of looks like?
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #8  
Old 05-17-2014, 06:48 AM
Registered User
 
Join Date: Apr 2014
Posts: 7
This is my climate control panel, I think it's gen II and it seemst to be quite rare thing on market, I would buy new one if there would be one reconditioned for sale.

[IMG][/IMG]
Reply With Quote
  #9  
Old 05-17-2014, 01:39 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Thanks for posting a picture. I believe that is dual zone manual climate control, a european thing it seems. I've only seen a few in pictures. Looks pretty cool though!

I would be willing to bet that it suffers from the same cold solder joint type problems as its automatic cousins.

If you are interested I'd love to go through it, recap and reflow it for you.

Otherwise new/used would be your next best bet:
http://www.ebay.com/itm/Mercedes-OEM-w124-EUROPEAN-Dual-Climate-Control-Unit-124-830-04-35-/121146504010
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #10  
Old 05-18-2014, 05:48 AM
Registered User
 
Join Date: Apr 2014
Posts: 7
That unit on ebay has EC (economy) button last, but on my one there is recirc button.
My connection on the back in also different.

I live in Australia, so it will be little bit costly to send unit there, but never know.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page