Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-09-2002, 09:32 AM
Posts: n/a
Angry Engine cuts out after 10 minutes

First, a big thank you to this forum which has helped me greatly in the past. Now please do it again!

Have W124 ī91 300CE. Car always starts easily, even after several daysīnon-use. However, after running fine for about 10 mins, the engine just dies - and thatīs it! I can get nothing out of it at all for at least 40 minutes. Then, usually, I can get the engine started, but unless I keep the revs at around 2000, it just dies again. Similarly if I try to put it into gear (auto shift) the engine just dies.

After about one hour, I get the engine going again and, although it runs a bit rough for a few minutes, I can usually get into gear and away. Thereafter, for the rest of the day, even if I park up for several hours everything is absolutely fine. Car starts perfectly and runs without any roughness.

Clearly this is something to do with a component that reacts to the engine warming up - perhaps changing the mixture, ignition timing or whatever. But what is it??

Please help on this as I am now living in Spain and itīs really hard to explain this to the Spanish Mercedes dealers - even if I trusted the local one which I donīt after he blew up my radiator!

All suggestions gratefully received.

Reply With Quote
Old 04-09-2002, 10:06 AM
Registered User
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
when did you last replace your fuel filter? that is a good
and cheapest way to start hunting!
Reply With Quote
Old 04-09-2002, 10:08 AM
Registered User
Join Date: Apr 2002
Location: nevada
Posts: 21
I had a similar problem w/ my 300e before. what was causing it was a bad fuel filter. You might want to check into that or you might also have a bad overvoltage protection relay. These parts are relatively cheap.
Reply With Quote
Old 04-11-2002, 07:01 AM
Posts: n/a
Engine cuts out...

Thanks to Joel and DesertRat.

As you say, this is a cheap(ish!) item, so itīs certainly worth checking, but I suspect it may be more complicated because of the repeatability of this problem. It ALWAYS happens about 10 minutes after starting - just about the time that something or other would be adjusting the mixture/timing or whatever, I suspect.

Another factor I have discovered is that, if I drive the car every day, it doesnīt seem to happen - only if itīs been left for a coulpe of days or more. Even more puzzling!

Still, I didnīt believe that resoldering the joints on my cruise control would fix it, but it did!


Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
Help! Engine Dead???? Breckman99 Diesel Discussion 17 05-09-2005 11:26 PM
Diesel vs. Gas Mercedes Rebe Diesel Discussion 36 12-31-2004 06:26 PM
'89 300 SEL AC Cuts Out After 15 Minutes Herekee Tech Help 0 08-30-2004 08:08 AM

All times are GMT -4. The time now is 01:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page