Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-1999, 03:25 AM
Beth
Guest
 
Posts: n/a
Hello, my 95 E420 drives well most of the time but occasionally at stoplights the idle speed jumps up and down rapidly from about 350rpm to 1000rpm. It does this whether the ventilation system is on or off. It stops if I put it in neutral and tap the gas. So far the problem is intermittent but I'm worried as my car goes out of warranty soon. Thanks for anything you can come up with. Beth

  #2  
Old 03-13-1999, 03:27 AM
Benzmac
Guest
 
Posts: n/a
There are many systems working in harmony to develop a smooth reliable idle. The systems are numerous. Since you are most likely not a tech who is going to be doing the repairs yourself, I will try to reply to you as if you will be speaking to your service advisor or technician about the problems.

The idle surge should cause a “check engine” light to illuminate on the dash panel of your car. If so you are in luck! The repair technician can retrieve the code stored in the Diagnostic Module. After retrieval, the technician should perform diagnostic work to find the exact cause of your complaint. There could be many codes in a series, but only usually only one caused the complaint and the “check engine” light illumination.

Some causes that I have seen are as follows: 1. The self-adaptation is at its limit. This means the engine is running too rich or lean. IE air leaks or faulty sensors. 2. The engine wiring harness is cracked. See the bulletin board for more details on this. 3. A broken throttle return spring 4. A faulty throttle actuator

I hope I have helped!

Benzmac
  #3  
Old 03-13-1999, 03:28 AM
jkurtz
Guest
 
Posts: n/a
I also have this same issue on my '94 e420. I have had the codes pulled and the verdict was the "Idle speed slider(Actuator)" was faulty. $1200.00 from MB, YOW! Anybody have a handle on rebuilt part? I am in Denver, CO.
  #4  
Old 03-13-1999, 05:29 PM
M.B. DOC.
Guest
 
Posts: n/a
BETH,
YOUR CAR IS EQUIPTED WITH AN "ELETRONIC"
ACCELERATOR. SOMETHING IN THE FUEL MANAGEMENT
SYSTEM IS SENDING INFORMATION CAUSING THIS
ERATTIC IDLE SPEED. BEFORE YOUR WARRANTY EXPIRES HAVE YOUR DEALER CHECK IT OVER.
PLEASE ALSO READ BENZMAC'S ARTICLE;
"CHECK YOUR ENGINES WIRING HARNESS".
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E420 Idle Arm Bushing Replacement? AtlBenz Tech Help 0 06-04-2004 04:05 PM
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 11:25 AM
94 E420 stalls at idle!!!! chadman Tech Help 4 04-11-2003 11:59 AM
1997 E420 surging idle Diveguy Tech Help 6 11-23-2002 11:43 PM
97 e420 rough idle issue thugmotor Tech Help 6 08-19-2001 01:59 PM



All times are GMT -4. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page