Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-16-2002, 09:31 AM
captaincrunch
Guest
 
Posts: n/a
Lightbulb 126 Climate Control Unit "clicking"-Update and possible fix

85 300SD, CCU(climate control unit - the push button) "clicking" noises. Only happened during cooling cycle, and only when the temp got to the point of regulation, when the CCU switches on/off to regulate temp in cabin. Was worse with bumps in road, even braking would increase clicking. Clicking was the internal "points" type switches in the CCU itself.

This was a rebuilt CCU. Figured it was a loose connection somewhere. But why would it do it only after A/C got to the regulation point and not all the time?

Pulled console cover, checked all wires. It's almost impossible for a wire to be loose there, everything is wrapped solid. Checked and pinched connectors for both sides of CCU. Still did it.

Checked Temp Sensor, near dome light. Working fine.

Checked Temp Regulator. Right side panel under glove compartment. Found that moving it would cause the problem. Pulled connector and checked and pinched connectors. Held wire harness tight against box and seemed to solve the problem. :p Taped the harnes tight there and replaced. So far, so good.

Problem? Maybe a bad connection or loose wire at the Temp Regulator was prohibiting proper amps to be provided to the CCU. The internal point type switches were not fully openning and therfore, with bumps or other changes in G-force would make contact causing the "clicking" noises? I don't know, but makes sense to me.

Did this last night. Won't know if it's the problem until I drive it a day or so. For 20 miles this A.M. there was no problem. Wait until it gets hot today at lunch.
Reply With Quote
  #2  
Old 04-17-2002, 06:51 PM
captaincrunch
Guest
 
Posts: n/a
Thumbs up

That seemed to fix the problem! Haven't had the problem return (yet). Hope this helps someone else. I know there were several people who experienced the same thing.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS 126 Parts: New Euro Headlight Parts, Bumper Chrome cam69ss Mercedes Used Parts For Sale & Wanted 0 01-07-2005 04:44 PM
"85 300SD transmission flare fix? Pro help, please Ron Johnstone Diesel Discussion 3 08-05-2002 12:48 AM
126 Seat Parts & Floor Mats - For Sale jgl1 Mercedes Used Parts For Sale & Wanted 0 03-29-2000 04:16 AM
124 & 126 CD Update Bill Wood Site Feedback 4 01-05-2000 02:11 PM
Ashtray removal on 126 to fix wood trim Robert W. Roe Tech Help 1 09-25-1999 09:53 AM



All times are GMT -4. The time now is 11:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page