Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-22-2002, 06:05 PM
Registered User
Join Date: Dec 2001
Location: Rocklin CA
Posts: 65
Rear Clearence on S500

Trying to troubleshoot a ride problem. What should be the clearence between the tire and the read wheelwhell. The fronts look to have about 2 to 3 inches. The rear on mine seems much less.

96 S500 Self leveling shocks and accuators on the rear.
I think something is wrong in my system. I have replaced the shocks and accuators.

Reply With Quote
Old 04-22-2002, 06:42 PM
Registered User
Join Date: Dec 2001
Location: Rocklin CA
Posts: 65
Sorry Accumulators

Not accuators, accumulators(nitrogen spheres).
Reply With Quote
Old 04-22-2002, 07:23 PM
Registered User
Join Date: Oct 1999
Posts: 1,562

Does the rear have a harsh ride? If so, was the hydr system flush and filter changed with the repl of nitro spheres?

Has the rear ride height been adjusted (higher) and just not to your liking? or is there rubbing problems?

Reply With Quote
Old 04-22-2002, 08:19 PM
Michael's Avatar
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Sounds like maladjustment-why did you replace the shocks? How many miles?
"If everything seems under control, you're simply not going fast enough" --Mario Andretti

1995 E500 street car
1986 Porsche 944 Turbo S track car
Reply With Quote
Old 04-23-2002, 01:41 PM
Registered User
Join Date: Dec 2001
Location: Rocklin CA
Posts: 65
I don't think they flushed the system. I check the resevoir and it was low. Bought a quart and added almost the whole thing. The ride was very rough. Rides low. Real Bouncy. Not tight at all. The clearence in the back (eyeballing from the side of the car seems like I have three inches top of tire to fendor flaire(not actual wheel well), and none in the back. Car rides smooth, but when I hit a rough patch of road or cross a major tranistion area(overpass) the car shudders particularly when the rear hits the trasition). New accumulators 500 miles ago. New shocks(put in at a local shop first, before I knew I had accumulators) 2000 miles ago.(did get the self leveling in the back).
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Subframe Bushings git0 Tech Help 5 11-23-2003 09:01 PM
Problem with rear dome light switch 420SEL William Tech Help 2 11-10-2003 03:46 AM
s500 very low in rear semi Tech Help 11 05-25-2002 01:18 PM
'95 S500 Rear End Squeak Noises farena Tech Help 1 11-26-2001 05:27 PM
'90 300se Rear Sags kevinjh Tech Help 4 05-09-2000 09:32 AM

All times are GMT -4. The time now is 12:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page