Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-11-2002, 06:33 PM
Dalcorn
Guest
 
Posts: n/a
Question W210 Door Lock?

I replaced the left rear door handle on my 1996 E320 (W210) with no problem then tried to do the same for the left front side. It took more force than expected to remove the door panel and the cable to the inside door latch (to open the door) was detached at the inside door latch end. On re-assembly, I realized there was no tension on the cable from the door lock to the inside release, the outside door handle had lost normal resistance, I could not push the door lock up or down, and the lever to which the door lock cable was still attached appears to be in an extended position and will not return to its normal position.

I suspect the door lock is toast. Does anyone have any prior experience with a similar issue?

I have a W124 CD ROM Service Manual and suspect that the procedure is substantially similar except that the cable appears to have replaced the door actuation. Can anyone confirm whether it is necessary to remove the locking cylinder on the door handle?
Reply With Quote
  #2  
Old 01-26-2003, 09:12 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
Exclamation same exact problem with lever

what ever happened to your door problem? how much to fix? please let me know as i cant even close the door. i too have 96 e.
Reply With Quote
  #3  
Old 01-26-2003, 10:25 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
Exclamation same exact problem with lever

what ever happened to your door problem? how much to fix? please let me know as i cant even close the door. i too have 96 e.
Reply With Quote
  #4  
Old 01-27-2003, 01:38 PM
Dalcorn
Guest
 
Posts: n/a
I foreget the exact sequence, but I removed the door handle and the lock and the cable unjammed. Everything reassembled with no need for new parts. It works fine now.
Reply With Quote
  #5  
Old 01-27-2003, 01:42 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
Exclamation

David
I have the EXACT same problem you described!!!! What was wrong with the lock?? and how much did you/they fix it for?? please help as I can't even drive the car.
Reply With Quote
  #6  
Old 01-27-2003, 03:51 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
Talking

David,
thanks for some encouraging news, i hope i just have to redo it!i'll try it maybe tomm. thanks!
Reply With Quote
  #7  
Old 01-27-2003, 07:48 PM
Dalcorn
Guest
 
Posts: n/a
My 1996 E320 is a W210. To get instructions on how to take it apart, I subscribed to the Alldata web site. It contained instructions how to remove and reassemble the door handle.
Reply With Quote
  #8  
Old 01-27-2003, 09:32 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
david,
your talking about the inside door handle right? that is the one you took out and reassebled? i think i can do the door handle w/o instruction, i'll try!
Reply With Quote
  #9  
Old 01-29-2003, 03:15 PM
Dalcorn
Guest
 
Posts: n/a
By way of clarification, I removed the exterior door handle and lock cylinder. As part of this process I fiddled with a mechanical connection somewhere and the jam corrected itself.

The underlying issue is that during removal of the door panel a cable got overextended and jammed into a position where it did not belong.
Reply With Quote
  #10  
Old 01-29-2003, 06:03 PM
94 E320
 
Join Date: Jun 2001
Location: Fairfax, VA
Posts: 437
I know the thread is about a W210 but can someone look at this thread and see if the problem is similar?

click here

i'm hoping that is the problem for me also :-)
Reply With Quote
  #11  
Old 01-29-2003, 10:11 PM
Registered User
 
Join Date: Dec 2002
Location: Southern California
Posts: 62
Talking Fixed!!!!

Same problem I had!!! just was jammed ! seems like its was over extended by the handle, just used alittle WD-40 to loosen it up. thanks everyone for ideas.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page