Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-05-1999, 07:29 PM
pbirch3074@AOL.COM
Guest
 
Posts: n/a
The speedometer light bulb(s) just went out on my C280. Can anybody give me a brief idea of what to do to make the change myself. I guess that once inside I should change all that are readily accessable at same time?

Will I need to get the replacment bulbs froma dealer or are they standard type auto bulbs avail at any autoparts store?
Thanks
  #2  
Old 04-05-1999, 10:55 PM
Benzmac
Guest
 
Posts: n/a
The bulbs are cheap so I would get them from the dealer so you will get the correct ones the first time around. You will need some dash hooks for the pulling of the cluster.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 04-09-1999, 02:15 AM
pbirch3074@AOL.COM
Guest
 
Posts: n/a
Benzmac-Thanks your reply.

Initial examination of the dashboard does not seem to indicate any easy access to the intrument cluster. Are the dash hooks required to pull the whole top of the dash away from the lower windshield area? Are there any fasteners to unlock first?

Appreciate any advice you and/or other might give on this.

Are there any repair books like Chilton or Haynes that might give some worthwhile insight on this job?
  #4  
Old 04-10-1999, 01:30 PM
Benzmac
Guest
 
Posts: n/a
The cluster comes out by itsself. The hooks are small tools with a tiny hook on the end of the tool to grab the cluster and remove it from the dash.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just "Renewed" the instrument panel, lights and gauges and odometer Eric Eliel Diesel Discussion 21 01-06-2012 01:17 AM
Instrument lights still dead; rheostat bypassed The Warden Diesel Discussion 13 04-08-2005 12:43 PM
Instrument lights dead The Warden Diesel Discussion 2 12-11-2004 11:18 AM
'92 300 E - No Instrument Cluster Warning Lights at Startup jgl1 Tech Help 1 06-27-2002 10:42 AM
Instrument Panel Lights - This Worked jcd Diesel Discussion 1 10-22-2001 12:47 PM



All times are GMT -4. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page