Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-1999, 12:31 AM
mbvia@sprintmail.com
Guest
 
Posts: n/a
1989 300E(6 cylinder) Mercedes, 57,000 miles runs smoothly, accelerates great, doesn't smoke, etc., 23 MPG. However, occasionally it cranks and runs perfectly for approximately 2 seconds and suddenly the engine stops as if ignition turned off. Repeat cranks and runs smoothly for 2-3 seconds and then dies. This will repeat itself until the battery is dead. However, if the negative battery cable is removed for a few seconds and then re-applied, the car immediately will crank and run for a variable period of miles (from 70-500 miles) before the above failure repeats itself. This has occurred 12-15 times in the past 4000 miles. I have replaced a voltage relay part #210 540 38 45 (Seimens SWK1763, 10A, 12V) but nothing changed. I have discussed problem with 2 different Mercedes Benz mechanics and they seemed stumped but could figure it out if I brought the car in when the problem occurred.

  #2  
Old 04-12-1999, 12:17 PM
Benzmac
Guest
 
Posts: n/a
I would check the fuel pump relay for starters. They have a high failure rate.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 04-13-1999, 01:24 AM
mbvia@sprintmail.com
Guest
 
Posts: n/a
Thanks for the reply. Can you describe for me where the relay is located? Also, assuming the relay was the problem, do you think I could disconnect a wire (or wires) to it and see if the car acts the same (i.e. runs smoothly for 2-3 seconds, dies; upon cranking, runs smoothly for another 2 seconds, dies, etc.)?

Thanks again!

MWV
  #4  
Old 04-16-1999, 02:49 PM
Benzmac
Guest
 
Posts: n/a
There is a black plastic panel just behind the battery. Remove the panel and you will see two small black relays one says Klima on top and one will say Kickdown. The fuel pump one says Kickdown on top. As for checking it the best way is to replace it. If it hasn't had a new one it needs one.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 04-17-1999, 01:02 AM
mbvia@sprintmail.com
Guest
 
Posts: n/a
I'll take a look at the panel behind the battery. You say to just replace it, huh? OK. Is there an alternative source for these relays other than the MB dealer?

Thanks again!

MWV
  #6  
Old 04-18-1999, 11:11 PM
Benzmac
Guest
 
Posts: n/a
Most all parts suppliers that carry any parts for the Mercedes will carry this part...

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #7  
Old 06-28-1999, 02:55 AM
tfarris
Guest
 
Posts: n/a
I seem to have a similar problem - engine on 1989 300E frequently stops suddenly then will restart in about 3-4 minutes. I had been trying to figure it out for about a month when suddenly the car completely failed to start. After reading this post, I started looking into a possible relay problem. I discovered that fuel pumps are not getting any power. I hot wired power to the fuel pumps and the car runs fine. I've searched for the relay that you are describing and can find nothing with KICKDOWN on it. The one in the general area that you described has the part number 002 545 92 05 along with KR0003 KPR and 05 8956 68 stamped on it. There are two other larger electronic components mounted nearby. What do I need to replace...fuel pump relay, fuel control module?????
  #8  
Old 06-28-1999, 08:49 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You are looking for the 2 relays located to the right hand side of that area behind the battery. The fuel pump relay looks identical to the AC control unit. Usually the fuel pump relay will say kickdown on it. If not look at the other relay and it should say Klima on it if so it is the AC relay and you are looking for the other one!
I can't remember the Part # off the top of my head. Sorry.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mercedes 300 SEL - Dies after short run time srbonne Tech Help 10 01-23-2005 07:31 PM
300 se dies then is hard to start SCOTTFISH Tech Help 8 03-17-2003 01:07 AM
'93 300 E3.2 Dies DYIMike Tech Help 1 10-15-2002 06:42 PM
300 sdl dies when hot dserge Tech Help 0 05-04-2001 07:20 AM
1992 300 CE dies Blizzak454 Tech Help 1 10-29-2000 10:21 PM



All times are GMT -4. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page